0.106: Light brightness stepping, better Safe Mode and person dialog

As I said, the history graph is not that important on a portable device.

The issue I am deeply concerned about is the entity view because there is nothing I can do to limit the displayed number before the page is loaded. If I could apply a filter and then click submit then I could limit the list.

But listing an html table with 700 lines on an iPad is not a big challenge for a browser. It is the fact that each line is an active element that fetch data and it seems to kill the rendering engine.

On a stationary computer you can see that the browser works hard. The html loads in 0.4 seconds and the. It takes around 6 seconds to load the data. And this is on an i7 with loads of RAM and gigabit Ethernet. The HA machine is also a real computer and not a Raspberry pi.

The entity page has become really heavy and for a mature installation like mine, it kills IOS Safari browsers. As I said 700 entities. Remember many devices represent many entities. A single Philips Hue motion sensor is also a light sensor, temperature sensor, and battery sensor. Each window and door sensor reports battery and temperature. Each Philips remote is a battery sensor and there is an automation associated with each button and long press. So that is at least 9 entities for a Philips remote. It quickly adds up. I have around 35 zigbee lights. I have around 15 MQTT type devices with multiple entities each. The Unifi integration adds all devices on the Wifi as an entity. . And 7 Amazon Echos and 7 Google Homes. An Apple Tv, a Samsung TV, a Kodi box. Two sirens. Two smoke alarms. It adds up quickly. Around 400 entities are device related. And around 300 automations. It sounds big but really it is not. You will all end there within a year if you are just a little serious about home automation. And we all are, right? Otherwise we would just have a Hue bridge and a couple of Echos.

1 Like

Same here! frustrating! @Petter_Aarak what did you do tofix it? Did you remove the deconz plugin/add-on and re-add it? I have a lot of zigbee devices and i am worried to loose them.

While I am still not quite near even 400 entities, I agree with you about the way the frontend loads those pages. Yes not many folks have 700 entities or even 400 devices, but it should still be a concern for everyone that if you had to add so many devices that would run into these issues. Probably kind d of an edge case so not sure the dev’s motivation to fix it, but having this fixed would at least give peace of mind to the rest of us that we can dream bigger about our ha systems. At least for myself with “only” 50ish devices and about 200 entities, I don’t want to think of such limitations as I brainstorm the otherwise seemingly limitless application of ha in the home.

Yes, delete decons from home assistant. Add it again and everything became normal. Now I see Circadian Lighting is not working properly :frowning: . Thank goodness it seems automation and script work OK :slight_smile:
so I can wake up to dim lights, radio and freshly cooked coffee

I had deleted integration and added again. HA added new sensor (new names). I had to made new automations based on deconz integration, but when I restarted HA, sensors became unavailable again. This is problem with this integration in 0.106 release!

I removed deconz plugin and re added it. After this sensors have new names - I had to made new automation based on new names. This is huge bug

But if i delete the addon, does all the zigbee entities also getting removed?

Yes but when You re-add integration they get back. In my situation they back but with changed names. After reboot HA they are unavaliable.

Anyone else having issues with Node Red not connecting to the HA nodes after this update?

entities are stored on decon and same on hue hub. entities must be removed from home assistant and everything became normal when I reconnect decon. i only have sensors on conbee and all philips and ikea lights on hue hub. i haven’t changed anything on light since i’ve only seen errors on the conbee and the sensors.

I can’t get the more_info for person displaying correctly - it just shows the same as previously? Does more_info only work if I am away from home?
image
(as I’m home it’s using the ping sensor instead of GOS but in my person config it has GPS as well)

Also, I suddenly seem to have 3 system generated cast users that I can’t get rid of?

The map card and page itself only shows users who are not_home so I would imagine this uses the same logic.

I am glad i made a full snapshot before the 106 upgrade today, i had to restore since the most of my Deconz sensors went unaccessible…
After restore to 105.5 and config from earlier today my HA is ok again :smiley: :ok_hand:

2 Likes

Hue hubs have rate limits. If you have a lot of lights on it and you have those devices in groups in HA, it’s a single call for each individual light. This causes rate limiting as you can only send ~12-15 requests to a Hue hub per second before the hub will rate limit requests (seriously dumb decision on Philip’s part). I understand why it was done (Hue groups don’t pass unique IDs, so creating entities for them has been problematic at best), but there needs to be something built into the integration to allow for groups to be enabled in addition to the configuration.yaml parameter.

Hue groups can be re-enabled via configuration.yaml, but for new users (especially those with large Hue systems), this is going to probably cause issues for them.

2 Likes

For the new “none” entity id in service calls how should it be specified in yaml.

edit: this is the winner. Thank you.

  action:
    - service: homeassistant.turn_off
      data_template: 
        entity_id: >
          {%- if ( states.cover.chicken_door.state == 'closed') -%}
            input_boolean.chicken_door_last_call
          {%- else -%}
            none
          {%- endif -%}

Not sure about the syntax but that could be done with a condition. No template required.

Is there an issue with the 0.106 image for Raspberry PI 3? When I try to upgrade, I get an Unknown Error on the frontend, and the system logs say:

20-02-27 02:20:17 INFO (MainThread) [hassio.homeassistant] Update Home Assistant to version 0.106.0
20-02-27 02:20:17 INFO (SyncWorker_6) [hassio.docker.interface] Update image homeassistant/raspberrypi3-homeassistant:0.105.5 to homeassistant/raspberrypi3-homeassistant:0.106.0
20-02-27 02:20:17 INFO (SyncWorker_6) [hassio.docker.interface] Pull image homeassistant/raspberrypi3-homeassistant tag 0.106.0.
20-02-27 02:21:28 ERROR (SyncWorker_6) [hassio.docker.interface] Can't install homeassistant/raspberrypi3-homeassistant:0.106.0 -> 404 Client Error: Not Found ("no such image: homeassistant/raspberrypi3-homeassistant:0.106.0: No such image: homeassistant/raspberrypi3-homeassistant:0.106.0").
20-02-27 02:21:28 WARNING (MainThread) [hassio.homeassistant] Update Home Assistant image fails

Anyone else having issues upgrading?

I decided to do the tried and true method in IT, and rebooted my PI from the HassOS screen, and after a reboot, I was able to upgrade to 106. No problems whatsoever with this upgrade, even with my Konnected boards. It all went smoothly. Woot!

Same here… after back to 105.5 everything my sensors are working

Fix coming in next point release

2 Likes