0.113: Automations & Scripts, and even more performance!

HELP!

When I upgraded from 0.113.1 to 0.113.2 it killed my server. All I could get was a 502 Bad Gateway error from nginx. I eventually managed to restore a snapshot and get everything back to where it was.

I decided to wait till 0.113.3 and it has done exactly the same thing, my log file has shrunk to 2kb and show this:

2020-08-01 19:50:24 ERROR (MainThread) [root] Uncaught exception
Traceback (most recent call last):
  File "/usr/local/lib/python3.8/runpy.py", line 194, in _run_module_as_main
    return _run_code(code, main_globals, None,
  File "/usr/local/lib/python3.8/runpy.py", line 87, in _run_code
    exec(code, run_globals)
  File "/usr/src/homeassistant/homeassistant/__main__.py", line 320, in <module>
    sys.exit(main())
  File "/usr/src/homeassistant/homeassistant/__main__.py", line 312, in main
    exit_code = runner.run(runtime_conf)
  File "/usr/src/homeassistant/homeassistant/runner.py", line 119, in run
    return asyncio.run(setup_and_run_hass(runtime_config))
  File "/usr/local/lib/python3.8/asyncio/runners.py", line 43, in run
    return loop.run_until_complete(main)
  File "/usr/local/lib/python3.8/asyncio/base_events.py", line 616, in run_until_complete
    return future.result()
  File "/usr/src/homeassistant/homeassistant/runner.py", line 108, in setup_and_run_hass
    hass = await bootstrap.async_setup_hass(runtime_config)
  File "/usr/src/homeassistant/homeassistant/bootstrap.py", line 107, in async_setup_hass
    config_dict = await conf_util.async_hass_config_yaml(hass)
  File "/usr/src/homeassistant/homeassistant/config.py", line 313, in async_hass_config_yaml
    await merge_packages_config(hass, config, core_config.get(CONF_PACKAGES, {}))
  File "/usr/src/homeassistant/homeassistant/config.py", line 711, in merge_packages_config
    error = _recursive_merge(conf=config[comp_name], package=comp_conf)
  File "/usr/src/homeassistant/homeassistant/config.py", line 640, in _recursive_merge
    error = _recursive_merge(conf=conf[key], package=pack_conf)
  File "/usr/src/homeassistant/homeassistant/config.py", line 648, in _recursive_merge
    if conf.get(key) is not None:
AttributeError: 'NoneType' object has no attribute 'get'

I have run Check Config and it came back clear against 0.113.3

Any help would be greatly appreciated

Can I request; When a new version comes out that there is a hyperlink at the TOP of the page that links to the new builds, so you click it and it takes you to the bottom of the page where the information/fixes of that build is listed? Will save on scrolling :slight_smile:

5 Likes

Anybody else having trouble adding devices to ZHA since 0.113.2 upgrade?

Actually I was right with this even before 0.113.3 was released. Still broken in 0.113.3.

Sorry to spam here but I was “removed” from participating in the home assistant github because asking for more inclusion for the android app. :man_facepalming:

2 Likes

Hello I just updated to 0.113.3 and it changed the states of my automations from Off to ON. Was this intended?

Unfortunately I don’t see any entries in IP-Bans. I don’t think the IP ban would apply if I can access it successfully from the same IP address but a different browser, would it?

Update to this issue: I forced Firefox to start in Safe Mode, and was able to get back in with my regular browser session. After restarting it to be out of Safe Mode the fix sticks and works properly.

1 Like

So you keep saying. It is getting repetitive and tedious.

4 Likes

reduce the debug level down to error.

Can anybody help me understand what’s causing such behaviour:

This code works fine:

sunrise:
  alias: Sunrise
  mode: single
  sequence:
  - repeat:
      sequence:
      - data:
          brightness_step: 2
          entity_id: light.sonoff
        service: light.turn_on
      - delay:
          seconds: 1
      until:
      - condition: template
        value_template: '{{ repeat.index >= 124 or states.light.sonoff.state
          == ''off''}}'

And this one stops after one pass:

sunrise:
  alias: Sunrise
  mode: single
  sequence:
  - repeat:
      sequence:
      - data:
          brightness_step: 1
          entity_id: light.sonoff
        service: light.turn_on
      - delay:
          seconds: 1
      until:
      - condition: template
        value_template: '{{ repeat.index >= 124 or states.light.sonoff.state
          == ''off''}}'

It would seem that the 0.113 update moved python to version 3.8. and there’s not wheel file available for tensorflow 1.13.2 and python 3.8. to use python3.8, you need to upgrade to tensorflow 2.2 or above.

i’m looking into options… perhaps a manual downgrade to python3.7 is possible on docker. cant seem to find the apt program so things are proving a little more difficult.

If you are on docker then within the home assistant container there is no apt. Why would there be? The container is based on alpinelinux, which uses a different packaging system.

Has anyone else noticed that CPU utilisation tends to ramp up with time since the 0.113 update?

It’s not much (on my overspeced system) but is completely different to the level average utilisation I was seeing on 0.112 and earlier.

I found this to be caused by the fact that my card is an entity in an entities card. Using the Airvisual card stand alone works fine

  - type: entities
    entities:
      - !include /config/lovelace/includes/include_aqi_woensdrecht.yaml
      - type: custom:auto-entities
        card:
          type: entities
          style: |
            ha-card {
              box-shadow: none;
              margin: 0px -16px -26px -16px;
            }
          title: Air quality
        show_empty: false
        filter:
          include:
            - entity_id: '*.luftdaten*'
            - entity_id: '*.u_s_*'
            - entity_id: '*.chinese_*'
            - entity_id: 'air_quality.*'
      - type: custom:fold-entity-row
        head:
          type: section
          label: More Waqi info
        entities:
          - type: custom:auto-entities
            card:
              type: entities
              style: |
                ha-card {
                  box-shadow: none;
                  margin: 0px -16px 0px -36px;
                }
            show_empty: false
            filter:
              include:
                - entity_id: 'sensor.waqi*'
              exclude:
                - state: '-'

wonder where the bug/issue lies, with the Airvisual card or with Lovelace…of course it could also be a user error :wink:

There have been some reports I think. Can’t find them right now. Symptoms included lock up and/or crippling slow down on lesser systems like pis.

2 Likes

Hi, where I can read info about that? I also have that problem, the use of the cpu goes up and ends up blocking

Yes, I’m in the same boat. Maybe zeroconf issues aren’t completely resolved with 0.113.3

You use the search function in the forum.

But I did it for you :slight_smile: However I am sure there was more than this thread: High CPU usage after 0.113

Thank you very much, I have been searching and reading several threads, I found one similar to my problem, in my case python3 seems to be what triggers the CPU consumption and blocks HA. Thanks again

My mistake, when i did uname -a i got ubuntu in the response so i figured it was an Ubuntu distro.

What packaging system does alpine use?