0.86: New Lovelace UI and Zigbee Management Panel!


#224

I think people have been…:wink:

Not to mention that sometimes, at first, you don’t know what you don’t know until you finally figure out what you don’t know after something breaks! :smile:


#225

You should see the release notes when it’s just a RC (when I usually go onto the first beta and then have to work it out for myself LOL)


#226

Yes they have been asking, after the fact they have done the upgrade. If you are unsure if you will be affected surely it would be prudent to wait and find out before blindly hitting the update button.


#227

Sorry @tom_l, I have to say it again…

I’m pretty sure I agree with you…


#228

Sure, but part of what you quote is in fact not in this forum thread, but are in the blog post. I thought that this forum post was supposed to reflect what is in the blog post. Specifically the following is missing from the forum post

The following things are not allowed in entity IDs:

  • No capital letters
  • No leading or ending underscores
  • No double underscores

#229

I agree, that sometimes people ask without doing a simple search on the forum that gives the answer in the first hit.

I also agree, that release notes should be read thoroughly before updating and again if stuff doesn’t work after updating.

However, I also must say, that often the release notes are not very informative and often also rather ambiguous.
Also, a lot of components are not documented very well.
Further, often the error messages are either very unspecific or the opposite with a lot of exceptions etc, which makes troubleshooting sometimes almost impossible without asking.

While most are very helpful in their answers, the type of answers with “do your homework” are somewhat demotivating for asking for help…

I have no problem with agreeing, that if stuff should be changed - even though it includes breaking changes - it should.
Almost every release does include breaking changes and every time this is followed be a week of frustrations and a lot of questions and answers.
If the documentation of breaking changes was sufficient everytime - one would wonder, if that is because users consequently are stupid or if documentation consequently lacks behind?

Anyway, what I find the most annoying about the river of breaking changes is, that as a consequence of this, examples are outdated quickly - you search the forum, GitHub etc and find some cool solution and try to learn from it - just to find out after hours of making it to work, that this-and-so-many breaking changes has been introduced since…

Overall, thanks for the software and all the help from everybody - just to add sine thoughts to the discussion :slight_smile:


#230

There are a lot of things that it is valid to be critical about with Home Assistant but almost all of them can be satisfactorily rebutted with the whole, well-rehearsed, ‘it is open source’ argument.

The time when I think there is justification for anger / disappointment / frustration (insert your reaction depending on how you are affected) is the way Breaking Changes are handled.

I really think ‘The Powers That Be’ should be doing a better job in this department. If for no other reason than to stop the perception building of a lack of caring, bordering on arrogance from the developers. Many people here have already made good suggestions such as pre-warning of breaking changes, more details about what they mean and so on but for me I’d like to see at least two relatively simple improvements.

Some central point of information devoted to breaking changes. A blog / forum post or a page in the docs for example. And following on from that point; really, the docs themselves should have some kind of indication of what and when (date, version number) changes were made.

Just my thoughts…


#231

Hey, Thanks for answer.

The log you are talking about is ordinary hassio log from GUI? Or I need to check different log via terminal?


#232

I agree … so ask…

SOLVED see the last line:

I updated yesterday my testbench RPi/Hass.IO and everything went nice and smoothly. I have tried to read and maybe understand the release notes with breaking changes. ( no capital letters, no leading or ending underscores, no double underscores, time and time_pattern …)

Today I updated my main homeassistant and basically I think everything went ok, but I got this:

image

Configuration.yaml looks:

    recorder:
      purge_keep_days: 1
      include:
        domains:
          - sensor
          - switch
          - light
          - binary_sensor
      exclude:
        entities:
         - sensor.last_boot
         - sensor.time
         - sensor.disk_use_
         - sensor.weather_wind_speed
         - sensor.weather_temperature
         - sensor.weather_symbol
         - sensor.weather_pressure
         - sensor.weather_precipitation
         - sensor.weather_humidity



# Enables support for tracking state changes over time
history:

# View all events in a logbook
logbook:

EDIT2 - I was blind:

- sensor.disk_use_


#233

There is a lot of focus from a development point of view on easy installation, configuration, etc. Not being able to simply ‘hit the update button’ (as many people seem to do) contradicts the whole Hass.io philosophy in my opinion. The Hass.io page actually mentions Easy installation and updates

However these breaking changes can not be prevented or solved without manually checking every sinlge part of your setup (especially the non documented ones :wink:). Looking at the comments and number of questions many people are not able (or willing) to do that.


#234

Senor.disk_use_ Should be popping out at you as invalid. It has a trailing underscore. sensor.disk_use would be the correction. It needs to be carried through your config everywhere it is used.


#235

Yes - sorry, I just figured it out and edited my previous post - I was blind - no excuses


#236

Just to share a different kind of experience, I just updated to the 0.83.3 version from 0.82.1 with 0 problems: The new Lovelace UI loaded perfectly, no warnings, no errors, everything seems to be working fine.

I will keep using the old interface for a while until I have some time to play with Lovelace, which is something I’m looking forward to to.

Thanks to everyone that makes this project possible!


#237

Can deconz coexist with this ?

If not I’ll provably hold of migrating since the switch button editor setup is for now much simpler than having to deal with deconz event mechanism in homeassitsnt.


#238

I think yes. Haven’t tried to mix, but it should definitely work.

I wish HASS would be easy to program as phoscon app. You are right, adding a Xiaomi switch or Tradfri remote is so much easier with the latter (try to program brightness up or down, with HASS, it could take you 3 hours lol)

Of course with phoscon you can control only Zigbee devices added to deconz and nothing else…, while with HASS you can control all of the devices.


#239

I’ve just made the switch to having my lovelace as the default and I just realized that there are no persistent notification pop up windows appearing as they did in the old UI.

I see that there is an “indicator” (if you can call it that…) in the top right corner but, TBH, it doesn’t really meet the reasonable intent of being a “persistent notification”.

Most people use the persistent notifications for things they really need to see. In my case I use them for severe weather alerts. I just realized that my pop ups weren’t working and in trying to figure out why they weren’t I just happened to notice the itty-bitty little orange dot in the corner. Clicked on it and there they were.

And using a custom theme only makes the situation worse.

Is there any plan to re-institute the persistent notifications the way they were on the old UI or does anyone have a work around to get the same functionality as the old UI?

EDIT To add:

And I also just realize that the “persistent” notifications don’t survive thru HA restarts. That doesn’t feel very persistent to me.


#240

Awesome 0.83.3 update was finally successful. Thank you all :slight_smile:


#241

Hi @gregg098 were you ever able to get your GPS Logger working using the external URL? I’m seeing a similar error in the GPS Logger Logs.

13:58:14 ERROR CustomUrlJob.onRun:86 - Unexpected response code Response{protocol=http/1.1, code=405, message=Method Not Allowed, url=https://XXXXX.duckdns.org/api/webhook/b8fb75eaxxxxxxxxxxxxxxxxxxxxxxxxxxxxx07788d9de0c28d}

#242

Same here:

2019-01-27 20:32:39 ERROR (SyncWorker_3) [homeassistant.components.sensor.scrape] Unable to extract data from HTML

Scraper broke without any change. Also in 0.86.2. Is there already a fix?


#243

I do have it working via a connection to my local instance, but not through cloud webhooks (Home Assistant cloud). I haven’t tried cloud webhooks again though since I posted this.

The instruction pages were updated a day after .86 came out with better instructions. Have you gone through those yet?