0.86: New Lovelace UI and Zigbee Management Panel!


#264

The instructions were literally right there in the picture that was posted.


#265

Sorry. I thought the picture was pretty clear. I could get more descriptive with step by step clicking instructions? Not really walls I feel like punching through here. edit: I’ll point to the dev-info page.


#266

But that has always been the way you switch between Lovelace and the old UI.


#267

I’m assuming that’s a picture of what shows in the backend on the info button? (even those it’s different colours, but whatever). My backend showed nothing … that’s what I’m upset about. Changing the UI made the frontend full of errors AND the backend was blank. Nothing to look at or click.

I went back to 0.85 and everything was working again. I then was able to get to the info button in the backend and click the Try our Lovelace UI and that worked in 0.85 I then upgraded to 0.864 and the frontend/backend is now visible. So, the issue was because I had never used the Lovelace UI and so it was erroring out until I looked at it with a previous version of HA.


#268

I don’t think so. If you never used lovelace before you would get an auto-generated lovelace. I’d say you still have some entity_id or time errors in your configuration (that are no longer crashing lovelace from 0.86.3) so check your log for those kinds of errors and fix them now. Also time_pattern/time changes. Again look in the logs.


#269

Can anyone confirm that the asuswrt component is or is Not working in v86.4 in docker for non-hassio builds?

I’ve seen many threads saying it is still broken but I just saw another thread that said it’s only broken in hassio.


#270

non hassio here, asuswrt still broken


#271

This deserves another thread rather than swamping the release thread.


#272

Thanks for the clarification.

You’d think that if something like that is broken and hasn’t been successfully fixed in several releases at a certain point as a developer you would drop back to a known good working version while trying to get the kinks in the updated version ironed out and plan to do the update in the next release.


#273

I haven’t gone through the update to .86 yet. When I do, if I want to start fresh with Lovelace should I just delete the ui-lovelace.yaml file I already have? I had previously installed the HassIO add-on to auto create the lovelace file, but haven’t really done anything with it.


#274

Also many/most 3rd party systems that require OAuth or similar (e.g. EcoBee) can’t share configurations since the refresh tokens diverge and you end up with both production and test locked out! I haven’t come up with a good mechanism for this yet, although as I am typing this up I realized that I should just create a separate “application” for each environment and then configure the differences as secrets on Dev and Prod. I will give that a try.

Still doesn’t fix ZWave. In the past I attempted to centralize ZWave on a separate instance and link with MQTT but that introduced a huge amount of lag and fragility that no-one was willing to deal with.

Regardless, you simply cannot have Dev and Test automations running simultaneously since it will introduce real effects in the house. Some sort of mocking interface will be needed. Maybe eventually we could create a historical log of events from ‘recorder’ and then re-play those historical into the Dev environment to verify if the eventstream is maintained – the external components could be also mocked based on expecting the historical stream.

It is a hard problem for sure.


#275

You can rename that file to old_lovelace.yaml. If you want to revisit it or use yaml mode for lovelace it might be useful later.


#276

Nevermind, radiotherm isn’t broken…it just renamed the thermostat differently so everything seemed broken.


#277

Uggh, My Automations Are Not Working Right Since 0.86.3
0.86.4 Didn’t Seem To Help Either. I Think I Have To Downgrade Back To 0.86.1 :-S


#278

That is nice for you. I presume you were just informing us, rather than wanting help.


#279

running HA within a docker on synology DS918+
upgraded to 86.1 , no problems
Had to do a system power for other service

can not get HA Backup and and running …
i have restarted 4 times … completed reinstalled the docker image and no luck

the only errors in the log file are :
2019-01-31 12:50:28 WARNING (MainThread) [homeassistant.components.http] legacy_api_password support has been enabled. If you don’t require it, remove the ‘api_password’ from your http config.
2019-01-31 12:50:30 WARNING (Recorder) [homeassistant.components.recorder] Ended unfinished session (id=367 from 2019-01-31 04:16:09)
2019-01-31 12:50:43 WARNING (MainThread) [homeassistant.setup] Setup of xiaomi_aqara is taking over 10 seconds.
2019-01-31 12:50:45 WARNING (MainThread) [homeassistant.components.upnp] Wanted UPnP/IGD device with UDN “uuid:5e936fca-fb25-42b1-a127-191f0aa431b9” not found, aborting
2019-01-31 12:50:46 WARNING (MainThread) [homeassistant.components.sensor] Setup of platform plex is taking over 10 seconds.
2019-01-31 12:50:46 WARNING (MainThread) [homeassistant.components.sensor] Setup of platform darksky is taking over 10 seconds.
2019-01-31 12:50:48 ERROR (SyncWorker_8) [pychromecast.socket_client] Failed to connect, retrying in 5.0s
2019-01-31 12:50:50 ERROR (SyncWorker_11) [homeassistant.components.light.yeelight] Failed to connect to bulb 10.0.0.74, Theater Room: A socket error occurred when sending the command.

No major issues that i can see

any ideas ?

LeeB


#280

To be honest I wish I had time to troubleshoot the underlying cause. I find this to be a fun and rewarding project. I just have so much real work on my plate that I can’t be much help unfortunately. For now I will stay with 0.85.1 until I have some free time to figure out what is going on. Sorry…


#281

just think that too … thanks


#282

let me know if you figure it out using the webhook using GPS Logger.


#283

I’m sure this is just a typo:

The following things are not allowed in entity IDs:
* No capital letters
* No leading or ending underscores
* No double underscores

The list of things which are not allowed needs to be negated. Presently, it reads as:
“No capitals is not allowed,” in other words, you must have at least one capital.
“No leading or ending underscores is not allowed,” which reads as you must either start or end with an underscore.
“No double underscores is not allowed” so you’ve gotta have a double underscore.

Sorry. I’m a software engineer. I can’t help it. :slight_smile: