0.87: SmartThings, Areas and Entity Registry UI.


#42

The native SmartThings integration will be very very helpful. Does this run locally or go via the Internet even when the two devices are on the same LAN?


#43

same here mqtt issue from my dafang camera (dafang-hacks)

2019-02-07 16:17:43 ERROR (MainThread) [homeassistant.components.mqtt.binary_sensor] Exception in async_discover when dispatching 'mqtt_discovery_new_binary_sensor_mqtt': ({'name': 'dafang motion sensor', 'unique_id': '7811dc711e62-motion-sensor', 'device': {'identifiers': '7811dc711e62', 'connections': [['mac', '78:11:dc:71:1e:62']], 'manufacturer': 'Xiaomi', 'model': 'Dafang', 'name': 'Xiaomi Dafang', 'sw_version': 'Dafang Hacks'}, 'icon': 'mdi:run', 'state_topic': 'myhome/dafang/motion', 'device_class': 'motion', 'platform': 'mqtt'},)
Traceback (most recent call last):
  File "/usr/src/app/homeassistant/components/mqtt/binary_sensor.py", line 67, in async_discover
    config = PLATFORM_SCHEMA(discovery_payload)
  File "/usr/local/lib/python3.6/site-packages/voluptuous/schema_builder.py", line 267, in __call__
    return self._compiled([], data)
  File "/usr/local/lib/python3.6/site-packages/voluptuous/schema_builder.py", line 589, in validate_dict
    return base_validate(path, iteritems(data), out)
  File "/usr/local/lib/python3.6/site-packages/voluptuous/schema_builder.py", line 427, in validate_mapping
    raise er.MultipleInvalid(errors)
voluptuous.error.MultipleInvalid: extra keys not allowed @ data['icon']

#44

Unfortunately still depends on the SmartThings Cloud.


#45

“command_topic_prefix” is no longer a valid configuration option, and yet the device sent it as part of the discovery string (it sent ‘command_topic_prefix’: ‘left’). That’s the error.

You can always configure the switch yourself and configure it properly, until whatever device that is gets updated to properly support the changes.

You can look at the discovery string and get all the information you need to manually configure the MQTT switch.


#47

“icon” is not a valid configuration option, and yet the device sent it as part of the discovery string (it sent 'icon': 'mdi:run' ). That’s the error.

You can always configure the binary sensor yourself and configure it properly, until whatever device that is gets updated to properly support the changes.

You can look at the discovery string and get all the information you need to manually configure the MQTT binary sensor.


#48

Thanks, that’s a real shame. If I were to go down the MTQQ route does that run locally?


#49

I am getting the same issue.


#50

When I try to submit the Personal Access Token in HA I get the following message and cannot proceed: “Unable to setup the SmartApp. Please try again.”


#51

Is there some chance of getting compatibility with the new SmartThings app? The old one no longer supports Samsung appliances, but the new one does. I have 2 Samsung ACs that are visible in the new app, but not the Classic.


#52

MQTT bridge is the same way. The limitation is unfortunately on the SmartThings side, as you need a connector app in the SmartThings cloud to bridge from ST to HASS or anything else (MQTT bridge SmartApp in the case of the MQTT route, new HASS SmartApp integration in this case).


#53

Yeah that’s the downside to these approaches. I’ve already got the MQTT-bridge setup and working so I don’t see a huge reason to switch unless it’s faster somehow?


#54

I’d probably say don’t bother switching if you’ve already got the MQTT bridge and it’s stable. But the new integration is definitely the way to go if you’re just coming into it fresh, in my opinion.


#55

Added system_health: in configuration.yaml

System_Health_1

After restart:

In log:
Log Details (ERROR)

Thu Feb 07 2019 13:33:49 GMT-0500 (Eastern Standard Time)
Received invalid command: system_health/info


#56

The solution was to update zigbee2mqtt to dev branch. see:
zigbee2mqtt Issue


#57

Looks like you forgot the underscore.


#58

Nope:

System_Health_2


#59

Sorry I couldn’t see it.


#60

Try moving it before the front end include you have there.


#61

Thank you.
Moving system_health: before frontend: solved problem:


#62

Chrome search (Ctrl-F) doesn’t work for me in the Lovelace raw editor, unless the search string is in view at the time. Love the new look, though.