0.88: Persons, Command line auth and event subscriptions


#122

Woody:
You need to give the config checker more time to complete. I had this same issue a few versions back and someone here told me the same thing.

“You are using pip version 18.0, however version 19.0.3 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.”

What you see above is when it it just getting started.

When I just did the check, I got a little bit past that part and then it paused, took another 10 min and then said it was ok.

It’s slow sometimes 20 min to finish…give it time.


#123

And what errors do you get when you use the correct format:

  alias: Secure Home
  sequence:
    - service: lock.lock
      entity_id: all
    - service: light.turn_off
      entity_id: all
    - service: switch.turn_off
      entity_id: all

?


#124
Error executing service <ServiceCall script.1550718691920 (c:35ae31c2c9b445ed821e85afb55ac133)>

#125

You haven’t had time to paste that, restart, run the script and get the error message, you’ve just copied the error message you posted earlier without trying.

It’s your system mate, I’ll leave it with you.


#126

well that is because I already did exactly what you posted is how I got the error in the first place


#127

nice try at looking smart though mate but when it breaks I will just put in all the entities comma separated like when I first learned how to do this, by no means this is a hard work around


#128

Someone beat me to it, but here’s the issue. https://github.com/home-assistant/home-assistant/issues/21374


#129

well home assistant likes this mess this was built in the script configuration and it passed configuration

and does not trip any warnings when executed

  alias: Secure Home
  sequence:
  - data:
      entity_id: all
    entity_id: all
    service: lock.lock
  - data:
      entity_id: all
    entity_id: all
    service: light.turn_off
  - data:
      entity_id: all
    entity_id: all
    service: switch.turn_off

and a screen shot of what I put in the script editor


#130

Thanks @fletch101e

I get it complete in a couple of minute.

I was wondering if the warning message was critical, but it seems it’s not.


#131

This is a good question. I’m noticing that it’s still not available. This is much longer than the normal delay in getting the docker release.


#132

I run my YAML split across multiple files. The config checker is coming back with an error but not sure which YAML file is the issue. Any way to debug this? The error is so generic could apply to a lot of places in the yaml (it’s a name key that is no longer accepted):

  • [name]. (See /config/configuration.yaml, line 47).

#133

@balloob any update on this? (Why docker image on docker hub has not been updated yet)


#134

Docker image for .88.1 is up (latest). The build tagged as .88.1 is building right now.


#135

I’m having an issue with the new mwc-button replacement for the paper-button in a custom fan control entity row card.

it went from this:

ex

to this after I updated to v88:

ex2

to this after I swapped “mwc-button” for “paper-button”:

ex3

and the best i can get it to look is this by removing the size constraints on the button and rounding the corners:

ex4

but then it also won’t automatically resize to the width of the card when you change the layout. I can’t change the font size and the font color doesn’t follow the theme font color like the old one did:

ex5

I’ve posted an issue on the HA polymer github but I’m really not sure if that was the correct place to post it.

Does anyone have any idea how to fix it?


#136

Do you have Dafang camera with Xiaomi-Dafang-Hacks?
Update - MQTT on it was fixed


#137

I had just tracked down this same issue about an hour ago: https://github.com/EliasKotlyar/Xiaomi-Dafang-Hacks/commit/647b6945f568abfc987904c1b5405ce7d634fb49


#138

I had it down to the dafang, but hadn’t got as far as knowing what exactly needed changing.

Thanks for the pointer, I did look a few days ago, but that fix wasn’t in at that stage. Timing!


#139

I got a warning for [name] in line 0 of my sensors.yaml. I will have to find the culprit manually I guess. :smiley:

B.t.w. I have no comments in the top of my file.


#140

For anybody that cares after playing around a bit I got the script builder to make the script a little cleaner and it executes with no warnings or errors using “entity_id”: “all” below is how the script configuration worked for me

  alias: Secure Home
  sequence:
  - data:
      entity_id: all
    service: lock.lock
  - data:
      entity_id: all
    service: light.turn_off
  - data:
      entity_id: all
    service: switch.turn_off

#141

I updated to 0.88.1 and all of my zigbee devices stopped working. I saw earlier in the 0.88 notes there were issues with the zha integration but it looked like they were addressed with the 0.88.1 build. Is that not the case?

I was able to roll back and be back up and running but is there anything I can help provide log wise from my setup to help with the issue? I’m more than happy to roll forward again to grab logs or test. The only obvious warning in my logs were the following:

2019-02-25 17:00:36 WARNING (MainThread) [bellows.zigbee.application] Unexpected response TSN=25 command=1 args=[[&lt;ReadAttributeRecord attrid=0 status=0 value=1&gt;]]

2019-02-25 17:00:36 WARNING (MainThread) [bellows.zigbee.application] Unexpected response TSN=24 command=1 args=[[&lt;ReadAttributeRecord attrid=33 status=134&gt;]]