1.5.0 Feedback

beta-testing
Tags: #<Tag:0x00007f1ba24e0560>

#196

Glad it worked out :slight_smile:


#197

This doesn’t explain it for me!


#198

I’m not sure if someone already mentioned it but I want to give my feedback:

For some reason the app on my iPad always asks me, if I want to turn on the location service.
When I say no, it asks me again.

When I say yes, it ask me to “Re-enable Location Access?”
Choosing “Re-enable” brings me to the privacy settings in wich everything is already turned on.
Choosing “Leave disable” it will ask me again and again and again.

Any idea what I’m doing wrong?
On the iPhone version I was able to turn on motion, since it’s available on the iPhone.

Also for some reason I’m getting “Login attempt failed” notifications from time to time.
I’m using only the new way for authentication. Looking into the tokens, I can see that my iPhone got:

https://home-assistant.io/iOS

The iPad on the other hand got

https://my-domain.duckdns.org:8123

not sure if that is related to the problem.


#199

:crossed_fingers:


#200

Well done @robbiet480 and @blackgold9 and anyone else I didn’t know about/mention.


#201

Just downloaded and wow the improvement in speed when I open it is noticeable. Just sitting here closing and opening again :smile: Great work!


#202

Have you actually gotten the iOS app to work with basic auth? I attempt to save the connection and I get prompted for the basic auth credentials, then the HASS credentials. I provide both and then get kicked back to the Settings screen with a “incorrect password” error.


#203

As others have said - you shouldn’t be using basic auth…


#204

Is anyone else seeing this in the HA log:

2019-01-15 17:00:19 WARNING (MainThread) [homeassistant.components.http.auth] You need to use a bearer token to access /api/ios/identify from 10.1.1.1
2019-01-15 17:00:26 WARNING (MainThread) [homeassistant.components.http.auth] You need to use a bearer token to access /api/services/device_tracker/see from 10.1.1.1

I am using the beta app and not using legacy auth on any of my devices.


#205

1.5 was released today…


#206

Sounded like that advice was for the people that didn’t realize basic auto was different than HA auth. I’m trying to use basic auth to add another layer of authentication at my perimeter.

My question stands; has anyone gotten the basic auth functionality to work in the newest iOS app release?


#207

For me version 1.5 it does not work anymore with lovelace custom cards.
(FIXED… it was unpkg prstrong textoblem)

Also…i cannot access local instance because i’m using duckdns ssl. With previous version it was working fine.


#208

I’m also having the issue where it doesn’t seem to track my location unless I “fire a one shot”

As it happens…I’m on an iPhone 6s…


#209

My location is updating perfectly on an iPhone 8s, where as on an iPhone 6s the background fetch is never fired where as some other events (like significant location update) are fired. Because of this zones enter/leave doesn’t work reliability.

No idea why.

Same app version (tried with the latest beta and the current new app store release 1.5.0), same settings.


#210

Great News! So if we were running the beta, do we need to uninstall it, and then go to the apple store to get the GA code?


#211

Just go to apple store and download new one and it will overwrite the beta


#212

Thanks! That was just too easy.


#213

My iphone app also keeps swapping out my address on the login page for

https://home-assistant.io/iOS

I never get prompted for a username and passwork. It just says “please wait”.
After a few seconds I get an error message

Error: invalid client id or redirect uri


#214

Looking at the change log in the iOS App Store, it actually says “support basic authentication on the UI only”… so maybe this version just has the option there, but the code to make it work isn’t in the 1.5 release? @balloob is that accurate?


#215

Same here. Other clients (browsers on PC and phone) have no problem working, as they seem to pass a valid redirect uri. But the new iOS app won’t work, just the way you describe, and there’s no way to change anything.