502: Bad Gateway with addons

Hi everyone,
Im kinda noob, so I dont understand many things. I have installed today HA Supervised, and I tried to use 2 new addons, Portainer and Zigbee2mqtt. I tried to configurate second, and I dont know if I have any error, but If I open both in the leftbar, it sends me a message that says: 502: Bad Gateway. I tried all I could searching information, any idea?

502 Bad Gateway is common anytime your addon doesn’t start properly and ingress tries to put you on the addons web interface. (its HA telling, Hey man, I tried to put you there but there’s an unknown server error - thus the 502)

Are you sure that your addons are configured to start correctly?

For instance what does the Zigbee2MQTT log say?

Hi Nathan.

I will show you the zigbee2mqtt log:image

Im not sure what is wrong in my configuration, and I guess that is the problem…

[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] socat.sh: executing…
[15:52:02] INFO: Socat not enabled, marking service as down
[cont-init.d] socat.sh: exited 0.
[cont-init.d] zigbee2mqtt.sh: executing…
[cont-init.d] zigbee2mqtt.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[15:52:08] INFO: Handing over control to Zigbee2mqtt Core …

[email protected] start
node index.js
Zigbee2MQTT:info 2022-05-17 15:52:22: Logging to console and directory: ‘/share/zigbee2mqtt/log/2022-05-17.15-52-17’ filename: log.txt
Zigbee2MQTT:info 2022-05-17 15:52:22: Starting Zigbee2MQTT version 1.25.1 (commit #unknown)
Zigbee2MQTT:info 2022-05-17 15:52:22: Starting zigbee-herdsman (0.14.27)
Zigbee2MQTT:error 2022-05-17 15:52:55: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2022-05-17 15:52:55: Failed to start zigbee
Zigbee2MQTT:error 2022-05-17 15:52:55: Check Zigbee2MQTT fails to start | Zigbee2MQTT for possible solutions
Zigbee2MQTT:error 2022-05-17 15:52:55: Exiting…
Zigbee2MQTT:error 2022-05-17 15:52:55: Error: AREQ - SYS - resetInd after 30000ms
at Timeout._onTimeout (/app/node_modules/zigbee-herdsman/src/utils/waitress.ts:64:35)
at listOnTimeout (internal/timers.js:557:17)
at processTimers (internal/timers.js:500:7)
[15:52:58] INFO: Handing over control to Zigbee2mqtt Core …
[email protected] start
node index.js
Zigbee2MQTT:info 2022-05-17 15:53:08: Logging to console and directory: ‘/share/zigbee2mqtt/log/2022-05-17.15-53-04’ filename: log.txt
Zigbee2MQTT:info 2022-05-17 15:53:08: Starting Zigbee2MQTT version 1.25.1 (commit #unknown)
Zigbee2MQTT:info 2022-05-17 15:53:08: Starting zigbee-herdsman (0.14.27)

Little update

Maybe show your config ?

data_path: /share/zigbee2mqtt
socat:
enabled: false
master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
options: ‘-d -d’
log: false
mqtt:
base_topic: zigbee2mqtt
server: mqtt://core-mosquitto
user: mqtt_user
password: mqtt_user
serial:
port: /dev/ttyUSB0
advanced:
log_level: info
pan_id: 6754
channel: 11
network_key:

  • 1
  • 3
  • 5
  • 7
  • 9
  • 11
  • 13
  • 15
  • 0
  • 2
  • 4
  • 6
  • 8
  • 10
  • 12
  • 13
    availability_blocklist: []
    availability_passlist: []
    device_options: {}
    blocklist: []
    passlist: []
    queue: {}
    frontend: null
    port: 8099
    experimental: {}
    external_converters: []
    devices: devices.yaml
    groups: groups.yaml
    homeassistant: true
    permit_join: false

First, Please enclose all code like above in triple back ticks so it’s formatted properly and easy to read.

Second what Zigbee controller do you use and what USB port is it on?

Finally, while I don’t believe anyone has any particular interest i your Zigbee network, you should redact your network key from public posts. Anyone with that key can take over your Zigbee network.

[quote="pablosuarez999, post:6, topic:421755, full:true"]
data_path: /share/zigbee2mqtt
socat:
enabled: false
master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
options: ‘-d -d’
log: false
mqtt:
base_topic: zigbee2mqtt
server: mqtt://core-mosquitto
user: mqtt_user
password: mqtt_user
serial:
port: /dev/ttyUSB0
advanced:
log_level: info
pan_id: 6754
channel: 11
network_key:

* 1
* 3
* 5
* 7
* 9
* 11
* 13
* 15
* 0
* 2
* 4
* 6
* 8
* 10
* 12
* 13
availability_blocklist: []
availability_passlist: []
device_options: {}
blocklist: []
passlist: []
queue: {}
frontend: null
port: 8099
experimental: {}
external_converters: []
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: false
[/quote]

Should it look like this?

Quick update, zigbee2mqtt web interface charged (no 502 gateway error) but it showed me some errors at the moment of pairing, then I reseted the addon, and I got the damn 502 error. I couldnt record the different errors I got.