.66.x Error. Task was destroyed, but it is pending!

Anyone know what this error means?
2018-04-02 12:32:27 ERROR (MainThread) [homeassistant.core] Error doing job: Task was destroyed but it is pending!
I haven’t seen it before the .66.0 update. It still exists with .66.1.

+1, I am seeing this and my HUE lights don’t work as well.

Did you read the release notes? There were some changes to this component.

It’s reported on Github:

1 Like

I don’t see any changes with hass.io 0.66 for HUE. The only issue that has been reported is around HUE sensors custom component
https://github.com/robmarkcole/Hue-sensors-HASS

I am seeing this too and I don’t have Hue lights

It’s not a Hue lights error. He was just saying that he had the same error, and his Hue lights weren’t working either.

We still don’t know what is causing this error. If you guys want, you can upload all your components you use on the github-link above, then we can try to find a common component, to check out, and try to find the culprit (if it is a component that is causing an error). There already is a couple that has listet up what they use, but the more people list components and experience, the better.

I don’t have a Github account.

I’m using:
Add-ons:

  • Duck DNS
  • Pi-hole
  • SSH Server
  • Samba Share

Components:

  • Discovery
  • Weather Underground
  • Logitech Harmony
  • Speedtest.net
  • TP-Link Switch
  • Netgear Device Tracker
  • Owntracks HTTP Device Tracker
  • Onkyo Media Player
  • IFTTT
  • Joaoapps Join
  • Join Notify
1 Like

see here

Thanks for the info brotherlegend, but setting up a different component to do what had previously been working without any issues is a workaround, not a solution. Having the developers actually fix the coding issue they’ve introduced is the proper solution.