Add Elna to Home Assistant?

Mine started working when I pulled the dongle and reconnected it while reloading the pure energie integration.

I forgot to respond here earlier, but mine also seemed topp have automatically started to be friends with HA around the same time as others mentioned above. I didn’t touch anything at all, so either an auto firmware update or an explicit unlock from the Eon side.
För the recorded: I was in contact with their support asking whether I could access the data, but never got any proper response.

Those of you who got it working, what software version and model do you have? I have 7.2 and SBWF4602 and here it not working

This is what works for me:
SBWF4602 by NET2GRID
Firmware: 1.7.14

Mime also started to work, I tried a bit before bot to no luck. I was surprised to see that it now works :smiley:

Connected my Elna today, delivered with version 7.2 and does not work. Did yours get updated automatically yet?

Yes, last week it all of sudden appeared in HA. version 7.14 now (which I believe is higher than 7.2. It is not 7.1.4, ie 14 is bigger than 2.

A question in Swedish, don’t think it matters since this is for E.ON Sweden only.

Vet någon om man kan se hur fördelningen ser ut per fas? Så att man kan se om man har en snedfördelning på faserna?

Oh great to hear. Hopefully mine will get updated as well soon. Yes I believe so as well 7.14 should be 12 versions higher than 7.2 :grin:

From what I read, the “Pure Energie” integration now works with more products from NET2GRID. As a developer of the integration, I’m curious about which brand, model and firmware version are working well (for documentation in HA) and who is still experiencing problems.

I work at Pure Energie and we currently offer to our customers what in Home Assistant is shown (tx to Klaas Schoute / @klaasnicolaas, the dev of the integration!) as Pure Energie Meter (PEM). When customers of ours contact us with questions for local API access, we send them a short document about that API. I have tried to attach it, but can’t seem to, so please find it at N2GSBLocalAPIaccess.pdf - Google Drive .

But fyi: afaik, Net2Grid, supplier of the devices, configures local access to the devices based on requirements of the customer (like Eon, Pure Energie…) and some want to secure/limit/shield local access, in which case the integration with HA will not fly (you can try to inquire with the energy provider on how to get access).

Hi, HA newbie since a couple of weeks…

I was playing around with my dashboard and found a card with three suggested enteties.

Two of them are apparently related to Pure Energie Meter, but they are not listed as enteties when i look att the unit Pure Energie Meter. What do they express?
sensor.pem_energy_production_total_compensation
sensor.pem_energy_consumption_total_cost

They seem to increase during the day, and are resetted to zero around 09:00 most days…

Har inte hittat denna funktion, Pure Energie integration beskrivs bara tre värden

  • Power Flow (W)
  • Energy Consumption (kWh)
  • Energy Production (kWh)

Hi, Today my homeasisstant integration stopped functioning.
First I suspected the last Version 2023.5.4. Restored version before that worked but still no connection to elna. Then diconnected and reconnected the device. Still no connection in HA.
Tested to ping it and got an reply. tried to browse to it HTTP error 401.
Checked tha app in the phone and it has connection to it. Checks the version and it’s now 7.41. Good Wifi signal. Anyone else that has lost connection to it?
I user Pure Energie meter to access it.

/Tba

1 Like

Hello
Got the same error, think it came yesterday.
ELNA version 7.41

1 Like

Same issue here, believe it started today. ELNA v 7.41, good wifi connection, responds properly on Ping. Can this be related to an ELNA upgrade?

1 Like

Same here. Dont know if there is a working process for reporting issues…
Seems very empty here: Issues · home-assistant/core · GitHub

Yeah, it stopped working for me yesterday as well. I also thought it was due to the 2023.5.4 update, but after restoring 2023.5.3 it still wasn’t working.
The Elna device is working as expected in the EON app so not sure why it doesn’t work in HA anymore.

Note that the pure energie integration and python package currently do not support the ELNA. It has never been tested and whether any adjustments are needed, there is also no API documentation known from Eon.

It may very well be that an update has changed something in the API :man_shrugging:

API needs auth now. I’m getting 401 when I try to open the IP directly. What is in it for eon, restricting the customers? I’m paying to them the same way if I use their app, or Home Assistant.