Add Volume to home assistant container?

I am using ser2net and socat to extend my z-wave stick from a remote box to my NUC running hass.io. I cannot see the /dev/ttyUSB0 or /dev/ttyACM0 unless I manually add it to the volume via portianer. Is there any way on a NUC to add a -v ttypACM0;/dev/ttyACM0 to the config that starts the homeassistant container? My manual change does not survive a reboot. Thanks!

You need to provide these volumes when doing “docker run”. And the local file/directory paths must be absolute, so -v /dev/ttyACM0:/dev/ttyACM0

The “run” settings should survive a reboot if you used “–restart=allways” with docker run and start the Docker daemon automatically (using systemd or SysV init)

I know when I do docker myself (which is how I’ve done it in the past) but with hass.io I don’t actually issue the docker run commands when setting it up. They come from somewhere from within hass.io and I haven’t found where to customize them, which is basically my question here.

1 Like