Adding Renault integration no longer works

Updated to 2023.4.5 today.

Though I’m not sure if thats the main fault here as I also had to factory reset the car Infotainment system and the app updated too, due to CarPlay stopping working. Anything amongst those three could have been the original fault.

So. I had the official HA Renault integration working, but this morning it showed as Unavailable on my dashboard. I tried reloading it, but it was just errors in the log. I deleted the integration and attempted to re-install. But when I get to logging in with my credentials, it simply comes back with “unknown error occurred” and fails to install the integration. My credentials are correct as I used the same ones to log into the website and the phone app today.

My previous logs from this morning when it seemed to fail to work say:

aiohttp.client_exceptions.ClientResponseError: 403, message='Forbidden'

Logger: homeassistant.config_entries
Source: components/renault/renault_hub.py:59 
First occurred: 11:56:55 (1 occurrences) 
Last logged: 11:56:55

Error setting up entry xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx for renault
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/config_entries.py", line 383, in async_setup
    result = await component.async_setup_entry(hass, self)
  File "/usr/src/homeassistant/homeassistant/components/renault/__init__.py", line 29, in async_setup_entry
    await renault_hub.async_initialise(config_entry)
  File "/usr/src/homeassistant/homeassistant/components/renault/renault_hub.py", line 59, in async_initialise
    vehicles = await self._account.get_vehicles()
  File "/usr/local/lib/python3.10/site-packages/renault_api/renault_account.py", line 62, in get_vehicles
    return await self.session.get_account_vehicles(
  File "/usr/local/lib/python3.10/site-packages/renault_api/renault_session.py", line 188, in get_account_vehicles
    return await kamereon.get_account_vehicles(
  File "/usr/local/lib/python3.10/site-packages/renault_api/kamereon/__init__.py", line 239, in get_account_vehicles
    await request(
  File "/usr/local/lib/python3.10/site-packages/renault_api/kamereon/__init__.py", line 160, in request
    http_response.raise_for_status()
  File "/usr/local/lib/python3.10/site-packages/aiohttp/client_reqrep.py", line 1005, in raise_for_status
    raise ClientResponseError(
aiohttp.client_exceptions.ClientResponseError: 403, message='Forbidden', url=URL('https://api-wired-prod-1-euw1.wrd-aws.com/commerce/v1/accounts/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx/vehicles?country=BG')

Feels like Country should be “GB” and not “BG” for a start. But I feel like the issue is some sort of updated API problem?

Faulty credentials gives an “Invalid Authentication” error. So the credentials seem to be recognised.

Same error for Country “ES”

aiohttp.client_exceptions.ClientResponseError: 403, message='Forbidden', url=URL('https://api-wired-prod-1-euw1.wrd-aws.com/commerce/v1/persons/8c364bff-455e-4fa7-8b25-ebe62aac51c7?country=ES')

Also for country DE

Problem also Country FI

Same problem for country FR

same here for RO

I reported this on Github for the Node-RED Renault contrib. According to lskp1 there, it’s because Renault has changed an API key. The new key is on Github on his Pull Request and on the linked text, although how to make the change in the HA integration, is another issue.

1 Like

From other forums, it does look like an API issue, and not related to the country.

I don’t know how to implement adding the new API key, so at a loss. Until something official is done.

Same thing here in Italy (IT) after update 2023.4.5.

Forbidden with SE as well, since a couple of days.

Any idea how long these usually takes to get fix to official integration ?

And is there any hard core workaround steps available ?

same for me IT

Same for me in DE i also think it is a Problem of the API

same here from IT.

Same for me in SI

Same for me in en GB

I had the same problem.
Found a solution here: https://github.com/home-assistant/core/issues/91593
Now it’s working!

2023.4.6 solved this issue :wink: