Adding Third Reality Smart light switch to deconz

https://www.amazon.com/dp/B08TVZK8D6/ref=cm_sw_r_apan_glt_fabc_DVD7H1T53YHCJVB9QE7W I’ve read of other people here being able to add this switch to deconz, but I tried for hours last night. On one of the first attempts at pairing it showesd up as a light in deconz and home assistant, but I was unable to control it so I figured to remove it and then try again. I Since then I could not pair it at all. There’s been like 2 attempts at adding it as a switch that deconz said after searching “compound is prepared” but I don’t know what that means. I’ve reset deconz, the conbee ii stick, HA, the host machine and everything I can think of.

Has anyone had success in pairing this even after much difficulty? I’m thinking maybe it’s a defective unit.

Any help is appreciated. Thanks!

Just wanted to +1 this. I can’t get mine connected either. Deconz, Conbee II, HA.

I never got it working on Deconz or with ZHA. I ended up giving up and returned the item, leaving me with 1 dumb switch still, in my entire apartment :frowning:

Just added these switches to deconz. They show up as lights and are controlled as if they are lights (not switches).
Works in Deconz, Home Assistant, and Homekit via Homebridge.

It was confusing for me because I tried to add them as switches using the Add Switch button (with type Other), but nothing seemed to happen in the pairing window UI.
However, the blinking light on the switch turned off pretty quickly after the pairing window opened.

After a while I gave up and closed the pairing window. The switch didn’t appear in the Switch list.
However, I noticed it did show up in the Lights list.
Turning the Light on/off in Deconz does control the button!

I now have a couple of Third Reality buttons controlling old switches for some old fluorescent light boxes.
They’re loud and kinda janky, but they work.

In case you need to reset the switch, hold the button for ~20 seconds until the little led light starts flashing.

Glad that you got it working. I had it show up as the light but I wasn’t able to control it so I deleted it and never was successful again. You are able to control via home assistant I assume, not just the deconz interface?