Adding WAQI integration

I’m trying to add the WAQI integration, but seem to be getting stuck.

I’ve added the config, but as far as I can tell I’m not getting a sensor, and according to the log, its not even attempting to try and get the information.

here is my config:

- platform: waqi
  token: !secret aqicn_token
  locations:
    - wellington
  stations:
    - Wainuiomata Bowling Club, New Zealand

Any help on this would be appreciated.

I’ve learned that you need to add a station with it’s number.
The station you have listed above has the number @8523, I read somewhere that you need to write it in the configuration file as this:

- platform: waqi
  token: !secret aqicn_token
  locations:
    - wellington
  stations:
    - A8523

If that doesn’t work, try writing @8523.

I got it working like so in the end:

- platform: waqi
  token: !secret waqi_token
  locations:
    - wainuiomata

How did you determine that wainuiomata was the location you needed? When I use the website to find something for my location it ends up giving me a specific station, which is fine but since location is required in the HA integration it’s not clear to me what that value would be based on the station that comes up for my location.

Yer the instructions are a little wrong as it implies to get full name.

Think in the end I used the API manually to find out the location name, it was just wainuiomata instead of the listed Wainuiomata Bowling Club

1 Like

I’ve made an improved Waqi custom_component: https://github.com/bouwew/waqi-test/tree/main/custom_components/waqi-test

The improvement is mainly in the configuration, you can choose to search for a location, you’ll get a list of options to choose from when these are found.

You can also enter a single station based on the feed ID that is shown on the AQI website as the result of your own search for a single station.
You can also type in here and then it picks the closest station it can find, based on your location. I’m not exactly sure how this works though… It seems to work on my system :slight_smile: