AEON labs - Nano shutter new Firmware to handle blinds position

Hi,

A few months ago I bought a Nano shutter from Aeotec which is able to control the roller blinds. The intermediate positioning was not possible with the firmware at that time. Recently, they proposed a new firmware handling the positioning. It is available with a program to perform the firmware update here: https://aeotec.freshdesk.com/support/solutions/articles/6000229404-nano-shutter-zw141-update-z-wave-firmeware

The firmware udpate changes the manufacture id, from 0x0086 to 0x0371. I performed the firmware update successfully, but now, due to this new manufacture id, the device is not recognized by Home assistant and I can’t configure it from the GUI : “Aeotec Limited Unknown: type=0003, id=008d”

I’m using Hassio in a docker container on a Raspberry Pi.

I know this has to do with the right XML available at OpenZWave. It seems they added the corresponding XML a while ago: https://products.z-wavealliance.org/products/3693

I read different posts about other unknown sensors. I tried to use the manufacturer_specific.xml file, tried to update the whole openzwave folder by cloning their git repository, tried to replace the file inside the used openzwave repository, but nothing really worked.

I am looking for an advice on which process I should try to test (even if I already tried it) to make the device recognized and be able to configure it.
Thank you in advance for your answers.
Marine

Did you get any answers on this one? I’m having exactly the same problem

Nope, no answers.
One info though. It seems that the last devices added to OpenZWave are added to the 1.6 version, and that Home Assistant uses the last available update of the 1.4 version. Home assistant needs to wait for python-openzwave to release their 1.6 compatible version or look to alternative libraries.
Got these insights from this topic.

One way to get the new devices of the 1.6 version is to switch to zwave2mqtt. If I understood correctly, it could be a way but I was hoping someone answers and tell us a way to go with the current zwave 1.4 setup to integrate this Nano shutter device.

I managed to get the configuration options for the Nano shutter back in by modifying the zwave config file with the manufacturer specific XML from the 1.4 open wave DB while home assistant was stopped - when restarted it all became available in home assistant now under the zwave node. I just need to Do some testing to see if it works.

I’ve got a wall swipe attached to the Nano shutter as well. I have the engineering spec for it that defines the command config options but have to try my hand at converting it to the XML format. Something I’m a bit of a noob at right now.

Let me know if you need some more info on how I got the options back in. Maybe we can help each other get to the other side of this.

I can’t believe there’s not a simple method to add these additional parameters in HA, honestly the zwave stuff is great but a PIA to configure.

Unfortunately, no luck on my side. Here is what I did, from the RaspberryPi host, connected in SSH:

  1. Stop the docker container by executing this command:
    sudo docker stop homeassistant
  2. Replace the content of zw141.xml (which is the Nano shutter OpenZWave config file), located in the folder /usr/share/hassio/homeassistant/z-wave/open-zwave/config/aeotec with the content of the last OpenZWave version, found here:
    https://github.com/OpenZWave/open-zwave/blob/2e18ba844ff75965819c0dad74817a3178dbe8da/config/aeotec/zw141.xml
    (which happens to have been updated two days ago!! but I tested everything before this update, like you)
  3. Edit the manufacturing_specific.xml to move the 3 lines concerning the zw141.xml product, from the manufacturer id 0086 node (AEON Labs) to the manufacturer id 0371 (Aeotec Limited). The 3 lines in question, which are now moved:
<Product config="aeotec/zw141.xml" id="008d" name="ZW141 Nano Shutter" type="0003"/>
<Product config="aeotec/zw141.xml" id="008d" name="ZW141 Nano Shutter" type="0103"/>
<Product config="aeotec/zw141.xml" id="008d" name="ZW141 Nano Shutter" type="0203"/>

moved from node

<Manufacturer id="0086" name="AEON Labs">

to

<Manufacturer id="0371" name="Aeotec Limited">
  1. Start Home assistant by executing the following command:
    sudo docker start homeassistant

The ZWave node is still not recognized :thinking: (still displaying “Aeotec Limited Unknown: type=0003, id=008d”) and the configuration options are not available.

Out of curiosity, I also tested to modify the manufacturer_specific.xml file without stopping homeassistant, and when I restart after modification, it doesn’t override my modifications. So I’m wondering if I’m modifying the right files. But I don’t find any other locations where the OpenZWave files would be, on my configuration.

So yes I would like some more info on how you got the options back.

By the way, I will try with the 2-days-old new version of the zw141.xml file (revision 6!). But I have the feeling that I did not understand why my device is not recognized and that I am not performing the right modifications to get it back.

Updating the zw141.xml file to the latest revision (the 6th) released 5 days ago, doesn’t solve the unrecognized device problem.
@Ledfoot Have you tried with this last version, on your side ? Are you able to configure it properly to get the blinds intermediate positioning working?
And what about the wall swipe?

hey @marine - have not had a lot of time to look at this for a while. I’m going to try this over the weekend.

Have you had any luck?

Hi,
I experienced same issue adding new firmware v3.01 (even newer than existing 3693 update in existing ZW141.xml )
https://products.z-wavealliance.org/products/3742
I opened an Issue on GitHub - hope to get help in updating XML file…