Aeotec nano switch 2-state switch issues

Hi all,

I just bought the aeotec dual nano switch. I hope that you guys can help.

I’m having problems configuring it with a 2-state manual switch, where changing the manual switch state does not reverse the light state.

If I flick the manual switch to ON, then the light is ON and flicking the manual switch to OFF, the light will be OFF. This works fine. However, when the light is off and the manual switch is ON, if I flick the manual switch to OFF, the light will still be OFF. I’m expecting it to reverse the light state which should turn it ON.

Is this normal?

I have the aeotec G2 micro switch and not having any of these problems.

What are parameters 120 and 121 set to?

I’ve set it to 1. Is it working as expected for you? I might have a faulty switch?

I can’t say, I don’t own one.

You could try setting it to 4 (auto detect button mode).

I’ve tried that as well but didn’t work either…

Have you manually tried to set the mode?

“Turn the Wall Switch Off.
Press the Nano Switch’s Action Button 4 times within 2 seconds to activate switch identification mode. It’s LED should flash the colour blue rapidly.
Turn the Wall Switch On.
Wait 10 seconds
Test operation via wall switch and then HA.”

Be careful though when doing it this way as you are exposed to live voltages.

1 Like

This works. My Switch didn’t like to be changed via Hassio and physically pressing the action button on the nano switch 4 times done the trick.
Just make sure you see the blue light before trying to flick the physical light switch, caught me out a few times.

I contacted Aeotec support and they suggested to upgrade the firmware to v2.01. After upgrade, the toggle functionality works as expected! Thanks all.

Just wondering what sort of delay you see in the HA gui when you toggle the manual switch.
For me it takes perhaps 2 seconds to update the value on screen. That feels very slow considering the cheap EverSpring plug sockets I have update almost instantly when I press the manual on/off button on them.

yep that sounds about right. It’s pretty slow for me too.

What I am trying to figure out if whether I have got the config wrong, whether it’s a bug in HA, or whether AeoTec think one or two seconds is OK.

I really liked AeoTec, especially the idea of updating the firmware from the USB stick, but when a cheap EverSpring plug controller can update its status almost instantly it makes me think I should be heading to Fibaro.

I will raise a support ticket with Vesternet (who I bought them from) and also AeoTec.

Just out of interest have you updated your firmware to v2, and what settings have you configured on the Nano?

Also did you have a Dual Nano Switch with energy metering, hence the v2.01 firmware. I can only find v2.00 for my Dual Nano Switch (without energy metering)

The delay is normal with most Z-wave products, not just in Home Assistant. I have a few different Z-Wave switches.

The Z-wave protocol was reverse engineered by some nice people who wanted us to use it for free, and it may be that the opensource version (OpenZWave) is not quite so quick as commercial versions, but this is not a fault with your AEOTEC device.
Wit hthat said, I have had reporting delays even in commercial products such as HomeSeer and Vera. It’s not really a big deal for me. You learn to work with the slight delay.

If it is particularly when using the manual wall switch and having a delayed response, change Option 80 to Basic so it reports only minimal information to reduce the delay. This in particular may be helpful for the version without energy monitoring.