Aeotec Smart Switch 6 reporting configuration

Hello all

have been googling about setting up the desired reporting behaviour for my Aeotec smart switches. Still confused after reading a few previous discussion threads (but many thanks for everyone for sharing what they know already!), so thought would ask here:

  • Is my understanding correct that there are two types of reporting going on:
    i) through parameters 80, 90-92. This allows a wattage (only) report to be sent to Group 1 (typically the controller) upon change in wattage - Q: is it an OR operation between the minimum % and the minimum W thresholds?
    ii) through parameters 101-103, 111-113. This allows selected properties (e.g. W, kWh, A, V etc.) to be sent in report to specified groups (1, 2 & 3) at regular time intervals - Q: is this “group” concept the same as the one above or this does not refer to z-wave association groups?

  • Is there a way to set up the reporting so that selected properties such as W, A, V can be reported upon change in wattage? Essentially, all I want is for a switch to report W, A & V when it’s actually switched on, rather than sending all kinds of traffic when it’s off… Couldn’t seem to figure out a way :frowning_face:

Thanks a lot in advance!

These are exactly the questions I’m looking for answers on. Did you find out anything?

From what I read in the documentation and the tests I’ve done, you either get
periodic reports of W, Wh, A, V, (select-able as to which ones)
or
you get W only based on change in Watts.

I’m like you, I would like W, Wh, A, V based on change in W.
Anyway I posted the question to Aeotec.

The answer that I got back was that for threshold based reporting, that only W is reported.

@wmaker Thanks!

That’s a shame. Although they have an updated version of this switch called Smart Switch 7, and it seems that it provides what we are looking for here, according to the docs:

Also I just noticed that HomeAssistant has a bug, where you cannot really set the parameter 90 to True thorugh the Z-Wave config interface. Even if you select True it will still send False value to the device.
A workaround is to send the True value manually, calling the proper service like this:

Service: zwave.set_config_parameter
Service Data: {"node_id": 14, "parameter": 90, "value": "True", "size":1 }