Aeotec Smart Switch 7 (ZW175)


Got 2 of these today but totally bummed to discover that they are only picked up as “unknown” by HA. There is a xml for these units in the openzwave repo, so the work around should be pulling this xml file and manually implement it in my config. The question is how on earth do I do that? Im running HASSIO on a RPI3. Should I just wait for an OZW update in HA?

“unknown” is just a name, it doesn’t mean the device won’t work. Is there any functionality you think you are missing?

If you want to change configuration settings, you can do it without having the XML file installed, but using the zwave.set_config_parameter and a little work reading the manual or the 1.6 config file.

My solution was to clone the OZW config repo on Github to a local directory on the RPI and then tell HASS to look for the config files in the local directory. Worked like a charm :slight_smile:

I hope you took the config files from the 1.4 branch on OZW repo.

The master branch is 1.6 and the config files are not 100% compatible

Hey krmzn, I found this:

can you please help better explain how to tell Home Assisant to read it and to use to my badly discovered Aeotec Switch?