After Adding new Component - HASS Portal refuses connection back in

Hi All!

I installed HASS via docker on Synology and life went perfect for a few moments.

DSM 6.x
on Synology 415+

It managed to detect my Samsung TV, Wemo Switches/Sensors, and Yamaha Receiver.
So, i decided to take the next step by adding new (standard) components

  • taking baby step this time - started with System Monitor / CPU

sensor:

  • platform: cpuspeed

I copied the whole line from the Compnents Portal, did a “cut and paste” with pride (using note++), saved it, then restarted HASS.

I tried connecting back in SYnologyIPaddresst:8123, and it gave me a “connection refused” message.
I checked the instance status in Synology/Docker - all is well, it says “running”

I hit the browser refresh for the HASS Portal - same problem.
Then, did the restart of the instance within Docker by flicking the switch “off/”… then “on”

Tried again - same problem.

I decided to remove the CPU component out from YAML and restarted HASS.

I managed to get back in to the Portal.

Any idea what did i miss/ doing wrong?

Cheers
Erick
ps. I also noticed that all my detected devices disappeared

Anything in home_assistant.log?

hi ih8gates,

Thanks for replaying.

The log was not giving any sign… apart from picking up the presence of duplicate key

17-02-16 05:28:41 ERROR (Thread-3) [homeassistant.util.yaml] duplicate key: “sensor”
in “/config/configuration.yaml”, line 45, column 0
in “/config/configuration.yaml”, line 53, column 0

from my YAML config:

Any thoughts?

Cheers
Erick

Have you tried remedying that error? There shouldn’t be 2 sensor keys. Try:

sensor:
  - platform: cpuspeed
  - platform: yr

Hi!

I did the approach you mentioned above and it seems to work ok… (it allowed me in to see the Portal again)…
Though I do not see any display about the CPU speed yet…

I guess I need to read.more… to learn how to use this platform well…

Thanks
Erick

There’s a configuration validation tool to verify that your configuration works properly. I can’t remember it right now but it is in the guide. If your configuration is faulty it might very well lead to this behavior. When things break I usually start HASS from the terminal to get all information to catch the errors.

Cheers!