After Eventghost puts my Pc to Hibernation and I turn it back on it ignores the BIOS fan settings

posting this in here because the official eventghost forum is down and I couldn’t solve the issue via other forums I posted this in

I’ve had this issue ever since I did a fresh reinstall of Windows 10.

the fans go loud to perhaps around 40%ish speed

it seems though that regular software fan settings are still respected.

I don’t know if I want to choose that over Windows fan settings though because it seems unelegant for me since let’s say I use Speedfan, firstly, Windows will always boot up with quite the loud fan noise, a stark contrast to my otherwise dead silent Pc. Secondly, it adds up to clogging my already stuffed Taskbar tray. Thirdly, correct me if I’m wrong on this, aren’t BIOS processes more energy/processor-efficient than third party software and won’t this increase startup time a bit?

What I tried out to solve this:
Install the Mainboard Chipset softwares for my Gigabyte Z370M D3H-CF, the BIOS was already in place