After Power Outage 2 zwave devices connect but dont work

Both devices are Fan Switch GE 12730/ZW4002 this I believe is first gen as I have a newer one also but no issues with that one. I have used Zwave for about 7 years and never had anything like this.
I live in Fl and had power out for 2 days from Hurricane Ian. when the power came back on all zwave devices showed back up and worked these 2 fan switches if you use the wall switch or toggle switch in HA or even the fan entity with the 3 speeds all it does is supply power for about 1 sec to the fan then turns off
in the log it showed me turning it on then something turning it off. I have tried heal, I removed the switch and then readded it as a new name and same thing. so that rules out automations and such.
Then I removed it from zwavejs and rebooted HA. Took it out of the wall so removed power. once it rebooted reinstalled it in the wall and added it back. It shows the device but still either from the wall or toggle in HA it blips the power to the fan and thats it. I get a device could have an issue after a power outage or gets a power spike and is damaged but 2x of the same part number and none of the others have issues. Any thoughts of what to look at or try. Its probably something stupid I am over looking.

It’s probably the devices, sorry.

The 12xxx series Jascos (GE) all are very sensitive to electrostatic discharge damage. The fan controllera are the least susceptible of the bunch.

I lost 7 GE Jascos at the same time when power came back from the snow event in Texas, February a year ago.

You could call Jasco, thier warranty support recently has been outstanding, but their warranty is only 5 years from date of manufacture (you’ll find a date code sticker on the device which gives week of year) so i suspect you will be including them in whatever insurance claim you’ll be doing…