After updating to 0.88.1 automations & Z-wave devices working in unexpected ways

I have several automations that use Aeotect Multisensor 6 Zwave sensors to detect movement in rooms and turn on the associated Zwave light switch for that room. These have several conditions; one is time so it doesn’t turn on the lights in the middle of the night. After I updated from 0.87 to 0.88.1 now my light switches are being powered on full brightness at first motion and nothing has changed in my config at all. This is happening in all 4 rooms I use these automations for. Is it possible that the “time” condition is no longer supported in the syntax I’m using?

- id: '12342316272839'                                                                             
  alias: Auto Turn on Room Light daytime                                                         
  trigger:                                                                                         
  - entity_id: sensor.aeotec_zw100_multisensor_6_burglar                                           
    from: '0'                                                                                      
    platform: state                                                                                
    to: '8'                                                                                        
  condition:                                                                                       
  - condition: state                                                                               
    entity_id: sun.sun                                                                             
    state: below_horizon                                                                           
  - after: '16:00:00'                                                                              
    before: '21:00:00'                                                                             
    condition: time                                                                                
  - condition: state                                                                               
    entity_id: light.sienna_bed                                                                    
    state: 'off'                                                                                   
  action:                                                                                          
  - data:                                                                                          
      entity_id: light.sienna_bed                                                                  
    service: light.turn_on

Sorry, can’t help you, but why not use the lux meter in multisensor, so that you only turn on the light if there is low lux?

Then you doesn’t need the time.

- id: motionLilleBad
  alias: Motion LilleBad
  initial_state: true
  hide_entity: false
  trigger:
    platform: state
    entity_id: binary_sensor.sensor_10
    to: 'on'
  condition:
    condition: or
    conditions:
    - condition: sun
      after: sunset
    - condition: numeric_state
      entity_id: sensor.aeotec_zw100_multisensor_6_luminance_10
      below: 100
  action:
  - service: light.turn_on
    entity_id: light.bad_lille_471387
  - service: light.turn_on
    entity_id: light.bad_spejl

Thank you for the suggestion, I actually was using the Luminance sensor before this strangeness however I simplified my automation to try to isolate the issue. My lights were being turned on in the middle of the night at 100% brightness when my wife got up to use the restroom! Its like my house was being taken over by ghosts, but the ghost was my smart home playing nasty tricks on me…

The idea was if my alarm was set before 10pm it would disable the trigger. This worked well if we went to bed early since we set the alarm every night. Initial working config (has worked excellent for over 2 years until this week):

- id: '12342316272841'
  alias: Auto Turn on Master evening (motion / luminance)
  initial_state: true
  trigger:
  - entity_id: sensor.aeotec_zw100_multisensor_6_burglar_4
    from: '0'
    platform: state
    to: '8'
  condition:
  - condition: state
    entity_id: alarm_control_panel.adt_pulse
    state: disarmed
  - below: '1'
    condition: numeric_state
    entity_id: sensor.aeotec_zw100_multisensor_6_luminance_4
  - condition: state
    entity_id: light.level
    state: 'off'
  - after: '10:00:00'
    before: '22:00:00'
    condition: time
  action:
  - data:
      entity_id: light.level
    service: light.turn_on