Alexa capabilities Haaska

Tags: #<Tag:0x00007f3f193f75c8> #<Tag:0x00007f3f193f72d0>

Hello all,

I am currently a little bit stuck on trying to figure out the best way to configure blinds/covers in home assistant and alexa at the same time.
Yesterday I finally achieved to integrate HA with alexa with the haaska bridge, and discovered that lights were working fine, but blinds were identified as DOOR. So today I went a bit deeper into haaska, home assistant code and alexa api, and found at that alexa only has some sort of categories:

https://developer.amazon.com/es/docs/device-apis/alexa-discovery.html

And that blind/cover category doesn’t exist (something I can not understand why) and that those categories are controlled by some sort of capabilities, which in this case home assistant send base on the component inside home assistant, as far as I can see in here:

But then I found that the api alexa capabilities, were also limited in another way, which was the language, not all of them were spanish supported, which is the main thing I need:

https://developer.amazon.com/es/docs/device-apis/list-of-interfaces.html

So here is the question: Is there any way, or any recommendation to change alexa device to anything else apart from DOOR, on which I can exectute the following voice command:

Alexa turn up the blinds (in spanish)

Instead of creating a routine inside the app?

I have checked and it seems like something like speaker will allow this. But the speaker capability is only in spanish.


Apart form this, I also tried with the :slight_smile:

cover.DOMAIN that returns DisplayCategory.DOOR and I see in the code that AlexaPercentageController capability is called, but when executing it on lambda it does not appear:

 "capabilities": [
            {
              "interface": "Alexa.PowerController",
              "properties": {
                "proactivelyReported": true,
                "retrievable": true,
                "supported": [
                  {
                    "name": "powerState"
                  }
                ]
              },
              "type": "AlexaInterface",
              "version": "3"
            },
            {
              "interface": "Alexa.EndpointHealth",
              "properties": {
                "proactivelyReported": false,
                "retrievable": true,
                "supported": [
                  {
                    "name": "connectivity"
                  }
                ]
              },
              "type": "AlexaInterface",
              "version": "3"
            }
          ],

Only those 2, any reason why they do not appear in there?

Kind regards

Maybe try adding the following to your alexa: smarthome: config and see if Alexa treats it as a “light”

    entity_config:
       cover.blinds_01:
       name: Kitchen Blind
       description: Kitchen Blind 
       display_categories: LIGHT #Blinds/Shades not supported

Hello,

I have already lights for some of the ones I have:

The problem, comes that when I say:

Alexa turn on all the lights, then the blinds/shades will also action themselves.

And what in reality I wanted to achieve was saying, turn down/up the blinds, instead of active/power on, or whatever other state that is applied to a light.

Also I can see that the capabilities of lights are the followings:

    def interfaces(self):
        """Yield the supported interfaces."""
        yield AlexaPowerController(self.entity)

        supported = self.entity.attributes.get(ATTR_SUPPORTED_FEATURES, 0)
        if supported & light.SUPPORT_BRIGHTNESS:
            yield AlexaBrightnessController(self.entity)
        if supported & light.SUPPORT_COLOR:
            yield AlexaColorController(self.entity)
        if supported & light.SUPPORT_COLOR_TEMP:
            yield AlexaColorTemperatureController(self.entity)
        yield AlexaEndpointHealth(self.hass, self.entity)

But when I execute the lambda function I only can see the same as the DOOR ones:

"description": "light.luz_2",
          "displayCategories": [
            "LIGHT"
          ],
          "endpointId": "light#luz_2",
          "friendlyName": "luz 2",
          "manufacturerName": "Home Assistant"
        },
        {
          "capabilities": [
            {
              "interface": "Alexa.PowerController",
              "properties": {
                "proactivelyReported": true,
                "retrievable": true,
                "supported": [
                  {
                    "name": "powerState"
                  }
                ]
              },
              "type": "AlexaInterface",
              "version": "3"
            },
            {
              "interface": "Alexa.EndpointHealth",
              "properties": {
                "proactivelyReported": false,
                "retrievable": true,
                "supported": [
                  {
                    "name": "connectivity"
                  }
                ]
              },
              "type": "AlexaInterface",
              "version": "3"
            }
          ],

When you can clearly see that the displaycategory is a light.

Any idea on what I am currently missing? And any idea about the blinds issue?

Kind regards

Hello,

Any clue about this?

Kind regards

Moving to development, to see if someone can help me there :smiley:

Hello,

Any clue about this?

Kind regards

Hello,

Any clue about this?

Kind regards