Alexa difficulty to connect to HASS API over HTTPS?

Hi all,

I’m trying to hook up my Echo Dot to HASS, first step is to let it turn my TV on etc. I’ve followed the steps and the skill is in place. My HASS server (rpi 2) has a valid SSL and when I test the skill on the Amazon development website it connects to the API and execute the HASS scripts without any problem.

However, when I’m trying it with my actual Echo Dot, it says “there is a problem with the response of this skill” and the app shows a 403 http status error. In short, it somehow seems forbidden to connect to HASS. The strange thing is that everything connects and works while testing in the Amazon development environment…

Did anybody else face this problem and is there anyone that could point me to a solution or at least further troubleshooting? :slight_smile:

Many thanks!

Rob

There’s a couple of different methods for connecting Alexa and HA so it will help if you specify which one you are using.

Are you using Emulated Hue, HASSKA or custom intents?

I’m using the RunScriptIntent as demonstrated in the component tutorial. Not sure if that is a custom intent or HASSKA, I was only aware of the former and the emulated Bridge?

That would be a custom intent then - if you were using HAASKA (I spelled it wrong first time) you’d know it as you have to install a separate GitHub project and then tie it to HA.

Hue Emulated bridge is essentially like HAASKA; a way to access devices and groups in HA. But in this case it is doing it by emulating a physical Hue Hub via software:

But back to your original question; do you access your HA externally via a DDNS with just straight SSL, or do you have to include a port in the URL? AVS doesn’t like ports. There are ways around it but I just used port forwarding in my router to avoid having to setup something like NGINX.

Just a simple portforward here as well, nothing else. The ha instance is directly accessible with the main domain. I’m not sure if HA is the problem, as via the Amazon website everything is working.

Hmm. That’s what I’m doing, port forwarding traffic from 443 to 8123 on my Pi.

A 403 response generally indicates one of two conditions:

  • Authentication was provided, but the authenticated user is not permitted to perform the requested operation.
  • The operation is forbidden to all users. For example, requests for a directory listing return code 403 when directory listing has been disabled.

Could it be some kind of permissions issue?

I have no idea, again, via amazon website it works fine. Could it be a routing thing because the Echo Dot is in the same network as the Pi?

Well… the solution was… unplug the echo dot from power, plug it back and let it reboot. Works like a charm now :slight_smile: :slight_smile:

Strange though, looks like something didn’t update before.