Alexa missing some entities with Home Assistant Cloud

I have setup Home Assistant Cloud and am using an Echo Dot Three.
Integration was easy, quick, and painless.
I looked through the entities it found and noticed some were missing.
For example; I have a D1 Mini configured with ESPhome to give readings about my bedroom using a BME680 sensor.
When I look in the entities Alexa has access to the temperature from that sensor is there, however none of the other sensor readings are there, no gas resistance, humidity, IAQ, pressure.
Interestingly, I have the same experience with Apple Home using the Homekit integration.
I have tried manually typing those entities into the include list in my configuration file using


but this did not get those entities to show up (worked great for excluding entities).

I’d like to know if this is a limitation, like, does Alexa (and Homekit) not support these kinds of readings?
Or is there something else happening here?
Is there some way I can get these sensor readings to be available?

Probably it is the Amazon’s lack of support to these kind of sensors. I know it doesn’t support humidity, so i guess is fair to assume that these sensors are not supported yet by Alexa