Alexa's ugly light changes in ZHA with Skyconnect - no transitions

Well I gave it a try. :grimacing: Set up a Raspberry Pi with Home Assistant, installed the ZHA integration and tried to connect my Philips Hue light bulbs directly to Skyconnect on ZHA. So far, so good. Using a cloud a tunnel on a custom domain I managed to create my own Alexa skill and could import the entitities from ZHA including a group of three Philips Hue color light bulbs.

Now the sad part: They go on and off with a nice transition (400 ms I guess, standard) but when you change colors by voice command (“Alexa, set group to red”) or when you change the group’s brightness (“Alexa, set group to 50%”), even when you manually change these things in the Alexa app… there is no transition. Looks awful. Is it still not possible in 2023 to give these lights a standard transition in ZHA? Is there a workaround, anything? Because this seems like a deal breaker to me and I would rather go back to the Hue integration than having these harsh light state changes. :frowning:

Sorry for my frustration, I found the solution and wanted to share it with everyone. :star_struck: It was actually really simple. Using ZHA you just need to go to “Configure” and when you scroll down you will see an option for standard transitions. 0.4s is the correct standard value for Philips Hue. After setting this, everything worked nicely again. Tweak this value to your needs, for me 0.4s is perfect.

1 Like