Alexbelgium repo : 60+ addons

Hi ! Actually it was one of my main driver for creating the repo - being able to mount smb shares directly in the addons. I use Emby myself (plex clone) very well from HassOs.

On my rpi3b+ I have therefore my Emby server, which distributes the content from smb shares to clients

Honestly rather than reformatting you could have a specific partition to run it ; and keep your mac files until you do the switch. I don’t know MacOS architecture but I guess that should be feasible

Oh awesome, is that Double commander that lets you mount that stuff easier?

Another great thought, although I have a dinky 256Gb SSD for the main HDD.
I guess I could maybe use GParted or something after I’m satisfied.

1 Like

Indeed you could set aside 32Go to begin with, then see if you like what you see…

Doublecommander is nice but it is only a file explorer (alternative to my filebrowser addon)

For smb mounts, actually it’s done via the addons options. You need to define the smb share location (ex : //, and smb username & password, then it is mounted to /mnt/SHARENAME

oh I see.
And can you have a comma separated list I have two.

yes exactly, it’s available:-) as long as you have the same username/password

Here is an example from qbittorrent Home Assistant addon : qbittorrent (supports openvpn & smb mounts) - #31 by Milenco - Home Assistant OS - Home Assistant Community (

networkdisks: "//SERVER/SHARE,//SERVER/SHARE2" # optional, list of smb servers to mount, separated by commas
cifsusername: "username" # optional, smb username, same for all smb shares
cifspassword: "password" # optional, smb password
cifsdomain: "domain" # optional, allow setting the domain for the smb share
password, same for all smb shares
1 Like

I’ll look into this this weekend!

1 Like

Addition of new addon : portainer

Forked from hassio-addons/addon-portainer
Changes :

  • upgraded from 1.24 to 2.1.1
  • webui
  • ingress with nginx
  • ssl
  • password setting

So just a tip-toe into the water.
I added my NAS to the config, and I see it’s name under mnt but there’s no contents.
The logs don’t seem to indicate any failures.
Any troubleshooting tips?

Congrats on the first step :wink:
Which addon is that, qbittorrent ? A specificity of HA os is that the mount is specific to an addon, so won’t be accessible from other addons, even from the host.
No error message on the addon log? I guess the share is named “//IP/ShareNAS”
If you see no content perhaps it is an uid issue, is it set to 0/0 in the addon options?

It’s plex.
Yes, I’m ignorant to PUID and PGID.
I know that’s a thing in docker, I just don’t know what they mean.
Do I need to go into Portainer and look these up?

Nono, it’s just a reference to your user id and group id. You can set it up in the addon options in case your shared drive only provides access to your files for people with a specific user id. This is improbable though. You’re sure that there is no error message with “exit 1” in your addon log?

chown: cannot access '/config/plex/Library': No such file or directory
chown: cannot access '/config/plex/*': No such file or directory
[cont-init.d] 40-chown-files: exited 1.

I suppose it was not a glaring red error.
Some things are green like:

[16:12:08] INFO: Mounting external hdd...

So my eyes didn’t gravitate towards it.
Not sure how Supervisor’s log color scheme works.

But yea now special permissions for my NAS.
It is smbv1, but I checked that nice feature for people who don’t want to replace perfectly good hardware that’s internal to your network.

oh maybe I just wasn’t patient enough.
Now I’ve got some red glaring errors.

[16:13:43] FATAL: Unable to mount //<IP>/ShareNAS to /mnt/ShareNAS with username <USERNAME>, <PASSWORD>. Please check your remote share path, username, password, domain, try putting 0 in UID and GID
[16:13:43] FATAL: Error read : mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)
1 Like

Mmh… Now that’s a good news :slight_smile: seeing an error is the first step toward resolution. Are you sure about your path? Including the case?

The errors for chown are not really important since the files probably don’t exist if you haven’t completed the config due to the smb not available.

So I was trying to use the hostname.
The IP Address was what it wanted.
So I’ve got my NAS in there.
What about USB and Thunderbolt drives?

1 Like

Great! Glad it worked :slight_smile: for local drives you need to mount them as smb shares using the sambanas addon [New Addon] Samba NAS. (Mount external disk and share it )

I have mounting of local drive enabled for some addons, like emby, however it requires priviledged mode off and some people are turned off by those kind of addons as this exposes the host system

1 Like

ok so that add-on might be working.
I get a message when I connect my USB drive to the VM though (still testing before I switch this over natively.)
usb usb1-port1: Unable to enumerate USB Device
I wonder is FAT32 not supported?

I guess that would be depending on your VM… However if you are on a vm, couldn’t you mount the drives through the vm? If they are mounted to the /share folder at host (vm) level I think it will propagate to the addon

Well I directly connected them to the VM, like plugging it in if it were a real computer.
I was trying to simulate what would happen if I ran HAOS natively.
Originally I was going to run ESXi directly on my Mac Mini and have a HAOS VM and a Windows 10 VM for Plex, just because mounting drives is a pain for a ludite like myself on Linux.
I’ve gotten by with Linux, done some troubleshooting but I’m still not confident.

1 Like