Am I doing something wrong restoring with my z-wave

Tags: #<Tag:0x00007f73905f27a0>

I’ve tried doing a restore twice now and both times after restoring the network key does not get restored for my z-wave integration. The first restore was taking a full snapshot of from my home-assistant on Raspberry Pi 3, then reloading home-assistant, and then doing a Wipe & Restore. The 2nd time was taking a snapshot from the Raspberry Pi 3, and un-tarring the snapshot and then untaring the homeassistant.tar.gz into a config directory and mounting that resulting config into a home-assistant docker container.

Both times the “restore” seemed to work because the other integrations like konnect.io, Mobile App, and Logitech Harmony seemed to restore correctly. Also it seemed like the Z-wave integration restored because all the Nodes showed in the drop down but the majority showed up like Upstairs hall light (Node:undefined undefined) and it seems like I have re-“Add node” the devices. Also it suggests when I try to do “Heal Node” or something on one of the nodes it shows voluptuous.error.MultipleInvalid: required key not provided @ data['node_id'], this is the reason I don’t think the network key is being restored.
I haven’t re-added the nodes after this 2nd restore because I thought I’d check if there was something I could do to avoid re-adding them.

This is my first time using home-assistant and it is frustrating that doing a snapshot on a raspberry pi 3 and then restoring that snapshot on the same raspberry pi 3 (with a reformatted micro-sd) doesn’t work.

Thanks for any help on what I can do to avoid re-adding or what I’ve done wrong with the snapshot and restore.

So since it seemed like all that was missing was the network key I decided to try adding to the configuration.yml. I had located the network key in .storage/core.config_entries so I edited my configuration.yml like suggested in https://www.home-assistant.io/docs/z-wave/installation and added both the usb_path and network_key as pulled from the core.config_entries file.
After a stop and restart of my docker home-assistant with the newly updated configuration.yaml my Zwave devices all now seem to be in the “Complete” state for the nodes (except for one but it is a battery one that might just need to be woken up before it’ll be Complete).

So I’m still not sure why a restore does not pick up the network key for Zwave but if anyone else runs into this issue there is a way to fix it.