Analytics configuration missing

Tags: #<Tag:0x00007fc42c6b9548>

I just updated to 2021.4.0 and from what I read I should have the possibility to configure the analytics reporting from the Configuration->General tab.
But when I go there, I see no section for Analytics.

Is there a simple explanation/solution to this? I’ve tried re-reading the analytics documentation, but cannot see anything there.

See attached screenshot.

Currently, those options only show for “owner” accounts. You can verify if you have an owner account via your profile page at the top:

Or at Configuration -> Users.

A potential cause for this is if you forgot your password at some point and followed the old instructions which involved creating a new user account (that’d be created as “admin” and not “owner”).

You could try fixing that at the .storage/auth file. You’d want to find your account and change is_owner from false to true. Edit at your own risk and make backups first etc if you decide to go that route…

Or an easier method would be to just wait for the next patch release. That’s going to make the analytics settings available to administrator accounts too.

2 Likes

Right.
It turns out I no longer had an ‘owner’ in my system. Edited the auth file and now I have the analytics config. This should perhaps be mentioned in the documentation.
Thanks.

Same here, but editing the auth file did nothing for me :frowning:
Did you edit the file while ha was running? (I did and than restarted, but this did not help)

I stopped stopped HA, edited the file, and restarted HA.
Did you verify the contents of auth?

1 Like

I don’t think I verified the contents, because i’m not sure what you mean by this :stuck_out_tongue:
How do I verify it? I thought ha would load it in after a restart.

Did you open the auth file and see that the entry with your username now says:

"is_owner": true,

ah you mean a manual verification. Well I did that and it was true, but I double checked it again and it is changed back to false, so I will try to change it when ha is stopped.

Edit: That dit the trick. tnx!