Any Support for Midea A/C?

Yes, those Kaisai units are working with Midea Air without any additional configuration.

So your best chance is to mess around with Mac’s code or help him to support your device

In my case, the protocol is quite different from the ground up that the unit doesn’t even work with midea air (despite being midea branded and wifi/cloud controlled using the old apps)

i created a telegram group https://t.me/joinchat/BhU6LRytPXLsiqTIar0jqg
So that everyone can communicate better :joy:

2 Likes

Which app do you use? Nethome or Nethome Plus?
Need you to downgrade app’s version as much as possible.
if the app can run with your AC, tell me the version.

NetHome Plus (is default application for Kaisai) version 3.12.527.
Midea Air 5.0.2.628

The devices with the WiFi interface belong to residential line up. I’m not sure if they have the central control bus.

Check the PCB of the unit for a connector labeled “X Y E”. That’s the RS-485 bus for the central indoor control. There might another connector close by labeled “P Q E” or only “P Q”. That’s a RS-486 bus for connecting to the outdoor units.
It might be that only the multi split VRF indoor units have this.

Regards,
XYE

Hello, everyone, News about the new protocol:
Currently I don’t think I can get k1 key from local. I found that the data sent by the Midea APP is also “ERROR”. I also tried to send some messages to the device, and I still get “ERROR”. So, I suspend development. Hope others can.

Just to clarify, you suspend development on the new protocol or on your component and library in general?

yes.
The more difficult thing is that I don’t have a device running the new protocol.
This brought me difficulties when I needed to debug and capture packets in the LAN.
Although some friends in the group have related equipment, our time zone is different :joy:

But I will also update the old protocol.
For example, get the port and id of the device from the udp response of the device.

1 Like

@mac_zhou, well done on the great work supporting Midea AC!! Appreciate it!
I’ve been using Midea Air and NetHome Plus for a while now, the App itself is reliable but when integrated into HA was a nightmare, when I had a disconnect will have to restart HA to get the AC back to work.

Am using your integration in the past couple days and it is working fine, will report back if I have any issues. I have 5 Springer/Midea units, all of them with the K42MBWF wifi dongle. All of them same model, internal units are 42MBCA09M5 and external units model 38MBCA09M5.

I’m not an expert into the process of getting those integrations as native componentes instead of custom, but what is your willingness to add it as a native component and maybe with a configuration from the integrations interface in HA? I think that will help a lot with those not used with hands on in CLI, etc. Maybe using midea-discover to automatically find the AC on the network and populate HA, will help. What you think?

Hope you got enough coffee!! Appreciate your support!

Hello, I’ve a Maxa Pluma FDL 26R which I can control using Midea App or Nethome Plus, but it seems unsupported when I run midea-discover.
What can I do to help to support this model?

Thanks. Hope it helped you

Hello, i tried the file from @andersonshatch on my carrier crystal II ac unit (midea rebrand) and it’s working. I can change through various functions. Only issue is that off is not working.
Also a proposal: is it possible to extract outdoor and indoor temperature and have them as sensors? That would be awesome since we could have outdoor/indoor temperature through grafana.
Thanks

Sorry, no idea about the mode issue, I never really got my head around the commands the library uses to communicate and after adding the fan_only workaround, I’ve not been able to dedicate any time to it, nor do I plan to.

For temp sensors, no plans to add as individual entities. It’s real easy to add with a template sensor though:

sensor:
  - platform: template
    sensors:
      ac_outdoor_temp:
        value_template: "{{states.climate.living_room_air_conditioner.attributes.outdoor_temperature}}"
        unit_of_measurement: "°C"
      ac_indoor_temp:
        value_template: "{{states.climate.living_room_air_conditioner.attributes.temperature}}"
        unit_of_measurement: "°C"

Remember to use the right entity_id if it’s not living_room :slight_smile:

2 Likes

According to the docs, one should better use state_attr, because it doesn’t give an error, if not available. Sorry @andersonshatch, not meant disrespectful! :wink:

Avoid using states.sensor.temperature.state , instead use states('sensor.temperature') . It is strongly advised to use the states() , is_state() , state_attr() and is_state_attr() as much as possible, to avoid errors and error message when the entity isn’t ready yet (e.g., during Home Assistant startup).

That gives us:

# instead of 
states.climate.living_room_air_conditioner.attributes.outdoor_temperature
#use
state_attr('climate.living_room_air_conditioner', 'outdoor_temperature')
1 Like

When I setup the AC it seems like I get the below state. It seems to be connected but there’s 2 notable issues:

  • the live values are inaccurate
  • current_temperature seems to be in celsius rather than Fahrenheit.

Anyone know the issue I may be having? Thanks!

hvac_modes:
  - auto
  - cool
  - dry
  - heat
  - fan_only
  - 'off'
min_temp: 63
max_temp: 86
target_temp_step: 1
fan_modes:
  - Auto
  - High
  - Medium
  - Low
  - Silent
preset_modes:
  - none
  - eco
  - boost
swing_modes:
  - 'Off'
  - Vertical
  - Horizontal
  - Both
current_temperature: 32
temperature: 63
fan_mode: Auto
preset_mode: none
swing_mode: 'Off'
outdoor_temperature: 0
friendly_name: Living Room AC
supported_features: 57
1 Like

Cloud integration: If I don’t use (change anything) in AC for some time (hour?), the first command always reports failure. Also temperatures are update only when command is send to the cloud and HA never update’s its state if AC was for example turned off using remote controller or mobile application.
Is there any way to do something with it, maybe some form of active loop can be configured?

@mac_zhou I’ve got your code installed but it’s not properly connecting to my device, I’ve gone through the instructions 3 times just to be sure I didn’t do anything wrong. I have confirmed I have the correct IP address and double checked the ID from the QR code as well. I don’t know what I could be missing…
It shows the correct target temperature that I have set on the unit but inside HA none of my call service commands make any changes to the device, also it reports the indoor temperature as 32 when it’s really more like 69 or 70:

image

1 Like