API.AI API endpoint method not allowed

good morning,
I’m trying to configure api.ai but when I go to set the endpoint gives me the error “405 not allowed”. It seems to be the same problem there with alexa
my endpoint url is:

test 1: https://myserver.duckdns.org/api/apiai?api_password=mypassword
test 2: https://myserver.duckdns.org:8123/api/apiai?api_password=mypassword

I’ve tried to set router ports to redirect the internal port 8123 to external port 443 but doesn’t work.
Can yu help me please?

I have API.ai set up. Are you on linux or Windows?

~Cheers

I’m using raspberry pi 3 with noobs(debian)

First off on an unrelated note you can add your api password to the headers in api.ai NOT basic auth with the key-value pair

x-ha-access your_password

How are you testing your actions? Does it work without HA fulfillment?

~Cheers

I tried using the browser this url

https://myserver.duckdns.org/api/apiai?api_password=mypass

and via ssh on raspberry

curl -v -H “x-ha-access: mypass” -H “Content-Type: application/json” https://myserver.duckdns.org/api/apiai

but the error is same 405 not allowed.

Where you set the api password to use with api.ai ? (you can add your api password to the headers in api.ai )

The Error 405 Method not allowed is CORRECT you are using the HTTP Method “GET” with browser / curl. But the API only accepts POST requests. Did you actually try with the API.ai / Alexa to connect to your API?

~Cheers

In this moment I am trying with Api.ai but previously I had tried with Alexa.

Try to configure something in API.ai and see how it goes. It should work.

~Cheers