API key for homegraph no longer available

Tags: #<Tag:0x00007f7c4f37df20>

I am trying to setup google assisant on my fresh Hassio on a pi. But all guides mention I need an API key for homegraph api to enable “sync my devices” which I want. But generating an api key is not an option for me. Does anyone have a workaround for this? I have tried to find similar issues, but have yet to find a solution.
Any help greatly appreciated! :slight_smile:

did you ever overcome this hurdle?

Yes, I did :slight_smile:
Go to https://console.cloud.google.com/home/dashboard, from here, select your hassio project if it is not already selected. Now select APIs & Services -> credentials from the menu on the left.
From here you can create an API key with the create credentials button at the top of the page.
When it has been generated I selected restrict key and on this page I did a few things:

  • Under Application restrictions I selected HTTP referrers (web sites)
  • Under Website restrictions I added the external domain name of my hassio instance
  • Under API restrictions I selected restrict key and in the new dropdown I found homegraph and checked it.

Save and the key should be ready to use, hope this helps :slight_smile:

As i final note, I recently started using nabu casa cloud and definitely recommend it. This integration is way simpler, and you never have to touch it again. While setting it up manually requires you to refresh the hassio draft project every month-ish, as described here (https://www.home-assistant.io/integrations/google_assistant#troubleshooting-the-request_sync-service)

Thanks a lot but now I found out that the usage of API key is deprecated (check your log). The solution is to use a service account, which isn’t the problem.

My problem is that I use the integration behind a reverse proxy. I guess this is the reason why it doesn’t work correctly. In the google home app I click on + to add new devices. I select my test app. I see the login screen and I enter my credentials. Then there is a message that google is adding / or logging in or something like this. Then I’m back in the window where I can select my test app (or other devices, like philips hue). the test app wasn’t added to my google home account :frowning:

Any idea? I plan to create a video to show the issue