Apple TV error: Establishing a connection to

Has this ever been fixed? I have to restart the ATV a lot in order re-establish the connection in HA. Then it only lasts a few hours before I need to do it again.
Running 83.6 Hassbian

Exact same issue here…

I do nightly reboots but they’re often not enough and the problem resurfaces by mid-day.

Is there any hope for these Apple TV issues?

The only way I’ve figured out how to fix is is by rebooting the Apple TV. I have 4 in my house and this just isn’t a suitable solution.

Do other people have the Apple TV component working reliably? Even after a reboot, eventually this just happens again after a couple of days.

I’m seeing similar behaviour as well. Unfortunately I haven’t been able to reproduce the steps required to make it occur, otherwise I would have created an issue on the Github page.

Same problem here on 0.100.1. I have 4x ApplyTV 4th gens and they worked for a few weeks, but I haven’t been able to reconnect despite multiple reboots and disabling/enabling home sharing…

Thanks! Any updates on your progress yet?

I’m making lots of progress with pyatv but I wouldn’t expect any real updates to home Assistant before end of year. But it might be both earlier or later. Working as fast and hard as I can!

8 Likes

Appreciate your work on this! My ATV is the only thing I’m having to control via infrared now, thanks to Apple. :rage:

It was bound to happen (deprecation of legacy protocols). It was mainly I that was slow adapting, I implemented most stuff almost two years ago. So… But I will hopefully get something up and running by next week that is testable.

4 Likes

Thanks Pierre, we need your help.

I have pushed something that is testable now (far from complete), would love some feedback. Basic instructions are here:

Unfortunately I can’t test it right now. but your hard work is much appreciated. I currently use the workaround from chamberlain which works somewhat okayish for the time being. If I find the time to help test it I will try it. But I have the utmost confidence in you!

Thanks again @postlund for all your hard work!

Keep up the good work. I really want ATV to be working again.

A beta version of the component (that can be installed with HACS for instance) is now available here:

Be sure to read the instructions before installing.

I get this when trying to setup the beta. After putting in the first PIN.

I need at least the stack trace in order to debug. Can you check the log?

I got error when adding it manually as a custom component, bit after setting up HACS and installed the Appke TV beta from there it worked perfectly.

Ok, great! Main thing is that it works.

Thanks for your hard work on this @postlund. The beta integration worked perfectly for me!

Is there anything special required to also associate an apple remote controller? For some reason, I have never been able to get the apple tv to wake by using the media_player.turn_on service, however, it used to work for me via the remote.turn_on and that does not seem to have come across with the integration…