AppleTV error on 2021.10.0

I’m experience an error on ATV setup with this A problem occurred while pairing protocol MRP. It will be ignored. then after the 2nd pin, it just failed.

1 Like

update to 2021.10.1 still no luck. Got the same error for ATV

You need to use the beta version of the component for devices running tvOS 15:

Got it… thanks for the info

Quick question, do I need to install it via hacs or I need to do it manually? or Run the sh script?

Preferably via HACS so you get update notifications.

Got it…thank man… your addon is a lifesaver.

1 Like

How do I install the Beta version of the component? Sorry if this is an obvious question I am new to home assistant. Thanks

in this case you just need to search on HACS. The beta will be there to install

I can’t see it in HACS! Where exactly is? Thanks

You need to add repository to HACS first. Being in HACS, Intergations click on 3 dots icon in upper right corner, selct Custom Repositories and then add GitHub - postlund/hass-atv-beta: Beta version of new Apple TV integration in Home Assistant supporting tvOS 15 as Integration. Download repository from HACS, Itegrations page and add as any other integration in HA.

Thank You unfortunately it doesn’t work for me after reboot i try to add my apple tv but i have this error

  • the flow of the confluence cannot be charged
    I tried also to run the script before but nothing changed

Same problem here. After reboot I got this error popup: “Failed to load configuration flow”. Any chance to fix it?

Hi, i’ve same error HACS install but when ATV3 is automatically discover, the code pin association is still failed “unknown error” (twice Time/OS 14.1).
How coud get device UP in HA?

Remove the HACS install and verify again.