Ariela - Home Assistant Android Client


#1445

HI
Not sure what I am missing but after installing Ariela and selecting configure / next
You get an option for Wifi name but no next button ??


#1446

Very strange. Whats your phone display size?


#1447

Galaxy S8 screen resolution FHD 2220x 1080


#1448

I will try to reproduce and fix this asap.

Also, version 1.3.0.6 is out.
What’s new:
Version 1.3.0.6
Release date: 12 March 2019

  • updated German localization
  • fixed gray out issue with picture-entity cards
  • NEW: added Bluetooth HFP MQTT sensor
  • NEW: added Bluetooth A2DP MQTT sensor

What can you do with HFP / A2DP mqtt sensors:

  • will provide the last Bluetooth device connected to your phone HFP / A2DP
  • will provide location (if possible to retrieve) when a device connects / disconnect to your phone (useful for example to find location of your car, headphones etc)
  • will provide last known timestamp of the connection.

Documentation; http://ariela.surodev.com/2019/03/12/find-my-car/


#1449

Very cool new developments, looking forward on beacon detection support implementation…and hopefully on some new tries regarding Android Wear support.


#1450

Thank you, i am glad you like it. I will see what i can do about beacons and Wear.


#1451

I’m not sure if you have a place for bug reporting - so if you do let me know and I will post there…

I have an MQTT topic that currently generates multiple notifications in quick succession (this probably needs to be fixed on the devices end). BUT to circumvent getting dozens of notifications at once, I added a tag to the notification in my automation. I don’t know if I did it wrong (seems pretty simple) but it is not working. I am still getting multiple notifications from Ariela instead of the new one replacing the old one.

- alias: Person at Front Door
  trigger:
  - above: '75'
    entity_id: sensor.front_porch_person_score
    platform: numeric_state
  action:
  - data:
      data:
        image: http://IP:PORT/IMAGE.jpg
        tag: fdn
      message: Someone is at the Front Door
      title: Front Door Person
    service: notify.android

is something wrong in the above setup or is this a bug?
Thanks!


#1452

Hello,
Can you put the tag as a integer value and let me know if works?
Thank you.


#1453

You are correct!
It looks like it is an issue with the string still.
I saw on the HANotify a commit was added so that TAG is a string matching the “standard”, looks like maybe it is not working.
I did check my notify.py and it matches what I see in the HANotify you linked at the top of this thread.

Do you want me to put in an issue for this so you can track it?

Thanks!


#1454

Yes, string tag will not going to work since the Notification id’s in Android needs to be integer. I do not think something can be done regarding this unfortunately.


#1455

Hello all,

Version 1.3.0.7 is out.
What’s new:

  • add possibility to scroll content while setup (useful for small display)
  • fixed showing current thermostat state
  • fixed issue when not all items are shown in MQTT setup screen
  • added Russian localization
  • small UI improvements

#1456

Just wanted to take a minute to thank @Ionut for his work on Ariela. A native/properly supported Android client for HA has been lacking for sometime.

I’ve been looking for something to tie in with Sleep As Android to trigger an automation, since using with Tasker only let you trigger something based on the “smart period”. But thanks to your MQTT alarm sensor my problem has been resolved.

Love the widget functionality too, saves me from having to create a Tasker Scene to control things.

I’m not using the application to it’s full potential, would be interested in try out location tracking but don’t want to sacrifice battery life more than I have to.

Regardless, the application is developing at such a rapid pace it’s exciting to see what comes next, and hopefully the new mobile_app component will make things easier from a development perspective.

Keep up the great work @Ionut, you’ve scored yourself another paid user!


#1457

Hello @cryptelli i am glad you like my work, i really appreciate to hear all these good things.

- id: '1552465990326'
  alias: Car Position Automation
  trigger:
  - platform: mqtt
    topic: homeassistant/sensor/android_galaxy_s8_hfp/state
  condition:
  - condition: template
    value_template: '{{ trigger.payload_json[''last_device_mac''] == ''01:A0:59:1C:0F:35''
      }}'
  - condition: template
    value_template: '{{ trigger.payload_json.last_device_longitude is defined }}'
  action:
  - data_template:
      dev_id: my_car_id
      gps:
      - '{{ trigger.payload_json.last_device_latitude }}'
      - '{{ trigger.payload_json.last_device_longitude }}'
      gps_accuracy: 1
      host_name: 'My Car'
      mac: '01:A0:59:1C:0F:35'
      source_type: gps
    service: device_tracker.see

I created also a script that will create / update a device tracker entity. Example: make the car position appear like a device which you can see in the maps.

How it works:

  1. it waits for Ariela to trigger that the HFP (headphone) profile state is changed
  2. if the mac address matches the bluetooth car mac address, and the payload also contains the gps coordinates, then it creates / updates the device tracker entity

I hope this script could be useful for you guys.


#1458

Thanks, tried new version same issue, very keen to sue this but there seems no way to get past the initial config screen to be able to put manual info in. Tried un installing and re installing but no luck.
Also tried the 3 other resolutions on the phone down to 1480 x 720 but no next button ??


#1459

Got it working, cleared cache etc, entered different name in wifi and there it was and is now working


#1460

I am glad to hear it was sorted out.


#1461

Hi,

Installed the app, here everything ok. works great.
Just having problems for adding HAnotify to HA.
I am on 0.89.1, so created folder custom_components/fcm-android and copied fcm-android.py in there. Then renamed it to notify.py.
Then put in my notify.yaml the folowing:

  • platform: fcm-android
    name: android

Problem is when i check my config it keeps checking and not giving me a good validation.
When i comment out the 2 lines i get validated.

Did i do something wrong?


#1462

HI not sure if you can help, just trying to test the notification by calling the service and sending
{“message”: “Anne has arrived home”} in the services just to test things
But get below error
Thu Mar 14 2019 11:22:07 GMT+1300 (NZDT)

Error sending message. Response 400: Bad Request:

NoneType: None
Any idea’s


#1463

Sorted out


#1464

Please fallow the setup instructions from https://github.com/MCrissDev/HANotify Because you use 0.89, you will have to create a folder in custom_components called fcm-android, and copy the py script from the repository and rename to notify.py

Glad you sorted it out.