Ariela - Home Assistant Android Client


#1465

That is what i did.
As you can read in my message.
But still got problem with validating.


#1466

I am not really sure of how on what should be in notify.yaml, but in that file should you put something like script notifications and not the config? That part you are trying to put seems like it should belong in configuration.yaml.
Example:

notify:    
  - name: android
    platform: fcm-android

#1467

Hello,

Version 1.3.0.8 is out.
What’s new:

  • NEW: support for timer entities
  • fix display of entities when no name is specified
  • fixed showing internal IP in settings
  • fixed picture entity display issue

#1468

I have separate yaml files for different things in ha. Like notify.yaml. in my config i have a include for this file.

But i tried it directly in configuration.yaml, but same problem.


#1469

Hello,
Can you please tell me the error it throws while checking the config?


#1470

A few weeks ago tag as a string was working. I made a change to the HANotify component to enable this. I don’t know what has changed in FCM but now the tag must be an integer.


#1471

thats my problem, i dont get a error , the validating proces keeps going on without giving me a green validation in the end.
And i dont dare to restart HA without a validated config


#1472

And if you do not put nothing related to fcm-android in configuration.yaml / notify.yaml it works?


#1473

yes, i get green validation in 2-3 seconds


#1474

What happens if you put this only in configuration.yaml

notify:    
  - name: android
    platform: fcm-android

Also be sure that the text is properly formatted.


#1475

@Ionut I have two questions.

  1. Is it possible to start Ariela automatically after the update (from Play Store)?
  2. Can Ariela send an event to HA when the notification is dismiss? Now it sends event only after click notification button.

#1476

Yep tried all that. Only thing that remains is that i copied a corrupted py-file. Will try tomorrow if that was the case


#1477

Yes & Yes :smiley: I will add these to my TODO list.

Ok, hope it will work.


#1478

I am on 89.2 and have the same problem as @Vdwkes. Once I put the notify: statement in the configuration yaml file when I go to ‘check config’ all it does is circle and never completes. Once I comment those lines out it checks the config and gives me a ‘config valid’ almost immediately. I have checked and recopied the statements several times so I’m sure there is no typo. I’m afraid to restart it without commenting those lines out.

I did create the folder ‘custom_components’ and then ‘fcm-android’ through windows file manager and downloaded fcm-android.py directly to that folder with windows also. I did rename it to notify.py.

I’m confused on what to do.


#1479

Great.
One more thing. Maybe support for TeslaUnread API?
TeslaUnread is responsible for displaying notification dots on application icons in launcher.


#1480

I will add this to my TODO list.


#1481

I tested on Ubuntu 18 + HA 0.89.2 and work like a charm. Does the HA console output says any error when you click the check config?


#1482

Hi,

I’ve got problem with notification setup. I did everything that is in instructions. But when I try to enable Firebase Notifications in Ariela app it shows the following alert:

notify.py is in the right folder: image

Config:
# notify
notify:
- name: android
platform: fcm-android

The log says that:
[homeassistant.components.http.view] Serving /api/notify.fcm-android to 10.8.0.1 (auth: True)

Do anyone had that problem? :slight_smile:


#1483

Go to Ariela -> Settings -> Common -> Device Name. Enter there a unique device name. I just tested and if that value if not set you will not be able to enable firebase. In the future i will autopopulate that value. Thank you for letting me know.


#1484

Hello all,

Version 1.3.0.9 is out.
What’s new:

  • fixed display issue with Sun & yr_symbol entities in badges
  • show Person entities as device tracker one in badges
  • NEW: add option to auto-start Ariela after application update
  • show picture not available when can’t retrieve camera image
  • fixed crash when updating notification
  • updated German localization