Assumed state not holding

Hi there, I want little slider switches on my card instead of the lightning bolts.
So I put this in configuration.yaml:

switch.arc_c1:
  friendly_name: Pomp vijver
  icon: mdi:pump
  assumed_state: false

But there are still bolts.

Tried to find answers, but can only find this solution, which does not work.

Can anyone help ?

Thanks in advance.

Did you restart Home Assistant after you made the change to configuration.yaml?

Yes, I did.
Forgot to mention that. :thinking:

Did you put this in the customize section like this:

homeassistant:
  customize:
    switch.arc_c1:
      friendly_name: Pomp vijver
      icon: mdi:pump
      assumed_state: false

If not, you should probably have an error under Configuration -> Logs.

Yes, I have it exactly like that.
No mentions in the log.

And the friendly name and icon also don’t work?

Indeed, they do not work either.

And you have only one homeassistant: section in configuration.yaml?

As an experiment, either remove or comment out the entire switch.arc_c1 section from customize and then restart Home Assistant.

After it starts, use Configuration > Customizations to customize switch.arc_c1 then restart Home Assistant again.

If that fails to work, I’m at a loss to understand why neither technique works for you.

I’ve tried everything you guys said, to no avail.
Even flashed a blank image, added the switch, made customization through configuration>customizations.
It appeared in the customization.yaml.
Rebooted, got no name and got the lighting bolts.
Now when I select the switch in Development Tools and set the assumed_state to false and press set state the card shows a slider switch! But when it is clicked it changes back to the bolts.
I am completely lost. :pensive:

I’ve got the exact same problem with covers assumed_state. It is not working at all.
anyone has a workaround ?

1 Like