Aten PDU intergartion not working

Good evening im trying to intergrate my aten pdu into HA. found a page showing it can be done but when i follow the intergration steps and check my configuration get the following error
Integration error: aten_pe - Requirements for aten_pe not found: [‘atenpdu==0.3.2’].