Athom Tasmota High Power LED Controller - WS2812 LED Lights - Home Assistant MQTT

I purchased an Athom High Power LED Controller (Tasmota pre-loaded) and a bunch of WS2811 LED strip lights (12V). Hooked it all up and works. I’m trying to add to my Home Assistant configuration.

This is what I have so far in my mqtt yaml config file:

light:
- name: "MDBedroomLED"
  unique_id: "MDBedroomLED"
  command_topic: "cmnd/MDBedroomLED/POWER2"
  state_topic: "tele/MDBedroomLED/STATE"
  state_value_template: "{{value_json.POWER2}}"
  availability_topic: "tele/MDBedroomLED/LWT"
  brightness_command_topic: "cmnd/MDBedroomLED/Dimmer"
  brightness_state_topic: "tele/MDBedroomLED/STATE"
  brightness_value_template: "{{value_json.Dimmer}}"
  brightness_scale: 100
  rgb_command_topic: "cmnd/MDBedroomLED/Color2"
  rgb_state_topic: "tele/MDBedroomLED/STATE"
  rgb_value_template: "{{value_json.Color2}}"
  effect_command_topic: "cmnd/MDBedroomLED/Scheme"
  effect_state_topic: "tele/MDBedroomLED/STATE"
  effect_value_template: "{{value_json.Scheme}}"
  effect_list:
    - 0 solid color
    - 1 solid colors
    - 2 color rotate
    - 3 color rotate faster
    - 4 random colors
    - 5 one clock
    - 6 chasing lights
    - 7 RGB chase
    - 8 RB chase
    - 9 GW chase
    - 10 RBB chase
    - 11 short rainbow
    - 12 RPP chase
    - 13 white chase
  payload_on: "ON"
  payload_off: "OFF"
  payload_available: "Online"
  payload_not_available: "Offline"
#  qos: 1
  retain: false
#  on_command_type: "brightness"

This is what comes up right off for the HA entity:

image

If I click the button to turn them on then it changes to this:

So it is working to some degree.

It is not showing the color wheel and scheme until it is powered on. It is also not reflecting the current settings of the controller (brightness is showing 0, nothing listed for color or current effect). Not sure if that is by design or because I have something wrong in my config.

The colors are also not correct. This is probably something in the controller since the Tasmota screen is also off.

Seems like the colors are all actually on the opposite side of the wheel (green is in the purple area, etc). Is there a way I can compensate that in the code?

I haven’t had much success looking for similar setups (using Tasmota and connected to HA). These LEDs have a data wire (individually addressable) not not PWN RGB lines.

Thank you for any help.

-Tim

In playing with it on the console (Tasmota), it looks like to set the color it should be:

color1 #RRBBGG

That is a little different than what the docs show (#RRGGBB). That may account for the color wheel not matching up.

color1 r,b,g also works (decimal values) but again blue and green are swapped from the docs.

Ok, I got it working better…

Colors are still flipped on the color wheel. Additional information does not appear until it is turned on BUT when you do the values are populated (color, brightness and scheme).

light:
- name: "MDBedroomLED"
  unique_id: "MDBedroomLED"
  command_topic: "cmnd/MDBedroomLED/POWER2"
  state_topic: "tele/MDBedroomLED/STATE"
  state_value_template: "{{ value_json.POWER2 }}"
  availability_topic: "tele/MDBedroomLED/LWT"
  brightness_command_topic: "cmnd/MDBedroomLED/Dimmer"
  brightness_state_topic: "tele/MDBedroomLED/STATE"
  brightness_value_template: "{{ value_json.Dimmer }}"
  brightness_scale: 100
  rgb_command_topic: "cmnd/MDBedroomLED/Color"
  rgb_state_topic: "tele/MDBedroomLED/STATE"
  rgb_value_template: "{{ value_json.Color }}"
  hs_state_topic: "tele/MDBedroomLED/STATE"
  hs_value_template: "{{ value_json.HSBColor.rsplit(',', 1)[0] }}"
  effect_command_topic: "cmnd/MDBedroomLED/Scheme"
  effect_state_topic: "tele/MDBedroomLED/STATE"
  effect_value_template: "{{ value_json.Scheme }}"
  effect_list:
    - 0 solid color
    - 1 solid colors
    - 2 color rotate
    - 3 color rotate faster
    - 4 random colors
    - 5 one clock
    - 6 chasing lights
    - 7 RGB chase
    - 8 RB chase
    - 9 GW chase
    - 10 RBB chase
    - 11 short rainbow
    - 12 RPP chase
    - 13 white chase
  payload_on: "ON"
  payload_off: "OFF"
  payload_available: "Online"
  payload_not_available: "Offline"
  qos: 1
  retain: false
#  on_command_type: "brightness"