Attaching URL to Pushover notification breaks in 0.106 - Not whitelisted

Hi, in 0.105.x and older I was able to attach a URL of a JPG to a Pushover notification which would then be downloaded by the Pushover client and displayed with the message, this no longer works and now complains that the path is not whitelisted:

2020-02-28 08:46:17 ERROR (SyncWorker_0) [homeassistant.components.pushover.notify] Path is not whitelisted

I know how to fix for a local folder but could I/should I be able to for a domain URL?

Example of the service call:

service: notify.pushover
data:
  attachment: 'https://someurl'
  priority: 0
  sound: bugle
message: Doorbell Pushed
title: Notification

Update - I see that this has been reported on github (#32236) https://github.com/home-assistant/home-assistant/issues/32236

I have the same problem and it looks like the GitHub issue has been closed without solving this. Has anyone found a workaround for pushover images? Please share yaml if so.

There doesn’t seem to be much chance of them bringing the functionality back citing security concerns. If you download the homeassistant 0.105.x files from github you can add the old pushover files as a custom component and get the URL functionality back although that will surely break at some point.

The other option is to use the downloader integration, and use that to download from your URL and attach the file using pushover

Thanks I’ll have a look at downloader. Shame this has happened, it’d been running perfectly for months.