(Auto)discovery docker container on ubuntu server

Hi,

I am migrating my homeassistant on a pi to my new home automation server (Ubuntu 22.04). And i am almost done, and love the results (Speed :-), zwave seems a lot more responsive). But there are two things i cant figure out why it is not working.

First is the autodiscovery of devices in my network. If you look at my docker-compose.yaml you see that i use my host network. (File below)

Second, i cant find any RFXCom devices. I use the same method for my zwave-js-ui container. I mapped the devices in my container to /dev/rfxcom and added the device in homeassistant using that usb port. (Enable automatic add is enabled, ALL protocols are enabled for testing)

Do i mis something here? Is there a way i can do some indepth debugging?

Thanks in advance!


version: '3.7'
services:
  homeassistant:
    container_name: homeassistant
    image: "ghcr.io/home-assistant/home-assistant:stable"
    volumes:
      - './config:/config'
      -  '/etc/localtime:/etc/localtime:ro'
    devices:
      # Do not use /dev/ttyUSBX serial devices, as those mappings can change over time.
      # Instead, use the /dev/serial/by-id/X serial device for usb devices
      - '/dev/serial/by-id/usb-RFXCOM_RFXtrx433_A11HELJS-if00-port0:/dev/rfxcom'
    restart: unless-stopped
    privileged: true
    network_mode: host

RFXCom diagnostics file

{
  "home_assistant": {
    "installation_type": "Home Assistant Container",
    "version": "2023.3.6",
    "dev": false,
    "hassio": false,
    "virtualenv": false,
    "python_version": "3.10.10",
    "docker": true,
    "arch": "x86_64",
    "timezone": "Europe/Amsterdam",
    "os_name": "Linux",
    "os_version": "5.15.0-67-generic",
    "run_as_root": true
  },
  "custom_components": {},
  "integration_manifest": {
    "domain": "rfxtrx",
    "name": "RFXCOM RFXtrx",
    "codeowners": [
      "@danielhiversen",
      "@elupus",
      "@RobBie1221"
    ],
    "config_flow": true,
    "documentation": "https://www.home-assistant.io/integrations/rfxtrx",
    "iot_class": "local_push",
    "loggers": [
      "RFXtrx"
    ],
    "requirements": [
      "pyRFXtrx==0.30.1"
    ],
    "is_built_in": true
  },
  "data": {
    "entry": {
      "entry_id": "f34f10fe13e2e312eba5a3a1fc01e218",
      "version": 1,
      "domain": "rfxtrx",
      "title": "RFXTRX",
      "data": {
        "host": null,
        "port": null,
        "device": "/dev/rfxcom",
        "automatic_add": true,
        "devices": {},
        "protocols": [
          "x10",
          "homeconfort",
          "homeeasy",
          "imagintronix",
          "keeloq",
          "lacrosse",
          "lighting4",
          "meiantech",
          "mertik",
          "oregon",
          "proguard",
          "rsl",
          "rubicson",
          "undecoded",
          "visonic",
          "hideki",
          "fs20",
          "fineoffset",
          "byronsx",
          "blindst1234",
          "blindst0",
          "ati",
          "arc",
          "ac",
          "adlightwave",
          "aeblyss"
        ]
      },
      "options": {},
      "pref_disable_new_entities": false,
      "pref_disable_polling": false,
      "source": "user",
      "unique_id": "rfxtrx",
      "disabled_by": null
    }
  }
}