Automation: ENOcean light.turn_on behaves like light.toggle ( Eltako FSR14 )

configuration.yaml

light:
  - platform: group
    name: Light_Group_Test1
    entities:
      - light.aussen_1
      - light.aussen_2

automations.yaml

- alias: Test1_ON
  trigger:
  - [something]
  action:
  - service: light.turn_on
    target:
      entity_id: light.light_gruppe_test1

This causes the lights to toggle.
No matter what state they are.
No matter if the states of the 2 lights are equal or differ.

Same behaviour if using service: light.turn_off !

If one is on, it turns off. If off, it turns on.

WHY ???

What sort of lights are you using?

I cannot reproduce this behaviour.

configuration.yaml

light:
  - platform: enocean
    id: [0xFF,0xAA,0x66,0x3B]
    sender_id: [0xFF,0x9C,0x77,0x3B]
    name: aussen_1
    
  - platform: enocean
    id: [0xFF,0xAA,0x66,0x27]
    sender_id: [0xFF,0x9C,0x77,0x27]
    name: aussen_2

Well the docs do say this:

Are you using this type of light?

If not you probably need to open an issue here:

I am using the Eltako FSR14-4x

Seems like I have to program conditions for every single light…

I have edited /components/enocean/light.py to make FSR14-4x work.

   def value_changed(self, packet):
        if packet.data[0] == 0xF6 and packet.data[1] == 0x70:
            val = packet.data[2]
            self._brightness = math.floor(val / 100.0 * 256.0)
            self._on_state = True
            self.schedule_update_ha_state()
        if packet.data[0] == 0xF6 and packet.data[1] == 0x50:
            val = packet.data[2]
            self._brightness = math.floor(val / 100.0 * 256.0)
            self._on_state = False
            self.schedule_update_ha_state()

I am really versed in Eltako / ENOcean - and I’d like to help to integrate it to HomeAssistant.
Maybe you can establish contact to people who work on it?

Or open an issue and get the light turn on/off services fixed for this device.

Just out of interest, what happens if you use the Developer Tools / Services page to turn on one of your lights that is already on?

(Trying to eliminate the group as a source of the issue).

It turns off! Same behaviour!
No matter how often I execute the task - the light toggles, regardless to the state of the light.

Please pay attention to my update to my recent post above (Maybe you can establish contact…) and to my update to the post above-above including the changed code in /components/enocean/light.py

thx tom, good night!

You have two options:

  1. Open an issue at the link I posted earlier, include your proposed solution.

  2. Create your own pull request for the integration.https://github.com/home-assistant/core/blob/ec4a9be4e6c29b6a515cc99db5a3e6a694acc212/homeassistant/components/enocean/light.py

1 Like