Automation list is there, but empty

This is something that happens to me since I started editing automations from notepad++ but didnt concern me since I was ok with it. I am pretty sure there is something wrong I did in my configuration, but I just remembered this problem and since I didnt find anyone else asking it, I thought I should give it a try.
Here we go:
My configuration.yaml is this:

automation: !include_dir_merge_list automations/

So I made a folder named automations and threw all my automation*.yaml files in there and have them split for practicality.
Everything works fine, BUT:

As you can see, while the list is there, every automation is empty. ALL of them. But they all work fine. I just cant edit them.

What I have tried:

  • Different formatting in notepad++ (eg. the action first, or the trigger first, or id first in the line.)
  • Deleted all the automations, created one from the frontend using the automation editor.
    That went south too…
    Actually when I did it, HA created an automations.yaml file in the home directory but the automation wasnt showing in the frontend. Dont know if it worked but anyway I took this file and moved it to my automations folder. Same thing happened: Automation showed in frontend, but empty.

I guess there is something wrong with my !include_dir_merge_list automations/ setup. What can I do to fix that? How is everyone keeping their automations clean and well organized, but also can see them in the frontend?

Turn on display of special characters in Notepad++. Are the lines terminated with LF or CRLF?

Should be just LF (UNIX format).

It is LF. I would like to point that this happens even when I create an automation from HA. When I tested today, all i did was to cut-paste the file into the folder I created.

I think it has something to do with the “dir_merge” setting.

I’m not completely sure but I think that once you use some program other than the HA automation editor to edit the automation then you lose the ability to edit them in the automation editor. I think there may be a way to bring it back (by using “id: something_named_like_this”) in your automation. I have never used the automation editor so I’m not sure if that will work. Look at the docs or do a search on here about that. Maybe it will point you in the right direction.

I had some time today, and did some tests.

  • First of all I setup the configuration.yaml to be like this:
automation: !include automation.yaml
  • Then I deleted all automations and created a new one using the automation editor.
  • Restarted HA and the newly added automation shows up and is NOT empty. (works)

  • Changed setting in configuration.yaml
automation: !include_dir_merge_named automations/
  • I moved the previously created automation into the above folder (automations) with the file name automation.yaml
  • I changed the formatting with the correct indentation to correspond to the HA docs.
- id: 'randomidhere'

became:

id: 'randomidehere'
  • Restarted HA and the original problem occurs. Automation shows but looks empty (not working)

  • Changed setting in configuration.yaml
automation: !include_dir_merge_list automations/
  • File stayed at the same folder as previous try, and only changed indentation to be correct.
  • Restarted HA and still having the original problem (not working)

I am not sure if this is a bug or it should be like this, but I thought I should share my findings…
Cheers.