Automation not working, always on

Hello.

I’ve been trying now for two days, but no luck, so I have to ask. I’m familiar with firewalls so I think I get the logic but still no luck.

The background:
I’ve set up nordpool ok
I’ve set up a slider to choose how many cheap hours I want to use ok. Everything so far ok.

Now I’m trying to automate this so that when nordpool price is below a set value, given by the slider when I select amount of hours I wanna use, to turn shelly on.

It turns on directly when automation i run, and never off even the price would go above set limit.

Where and how do I configure action for when the condition are NOT met?

If price is below slider value → lvv on
If price is over slider value → lvv off

I just cant figure it out.
How do i yell HA what to do if conditions in automation are not met, say the boiler is on because of price being chep, but then changes above limit, so it needs to turn off.

Can’t figure it out.

-Kalle

Verify your logic is not OR, should be AND.

Maybe post your current automation. Format it properly.

f6be36681e0da431418ec7781fb6c62712941803

use either “choose” or “if-then-else” in the actions