Automation not working anymore after 0.92.2 - SOLVED

I have this automation:

- alias: Nessuno a Casa Spengo Radio
  trigger:
    - platform: state
      entity_id: device_tracker.life360_maurizio_fabiani
      from: 'home'
      to: 'not_home'
  condition:
    condition: or
    conditions:
    - condition: state
      entity_id: input_boolean.radio_play
      state: 'on'
    - condition: state
      entity_id: media_player.salotto_audio
      state: 'playing'
  action:
    - service: script.turn_on
      entity_id: script.radio_stop
    - delay: 00:00:02
    - service: notify.telegram
      data:
        message: Spengo la Radio.

It was working good everytime it was triggered since i upgraded to 0.92.2.
Now it is not anymore triggered when i am not_home. What is changed in 0.92.2 regarding this?
P.S. The script radio_stop is working good when called manually…

Take a look in Dev Tools/states if the automation is enabled (on).

Yes, it is enabled by default

@maurizio53
Try - delay: ‘00:00:02’ (quote around the time section)
Look on Script Syntax page under delay, this might be the issue. What does the log say?

instead of quoting, changing to:

- delay:
    seconds: 2

might help.

The script syntax page says the delay time should be in single quotes.

The log says nothing… Now i disable the delay action (really useless) and see what happens…
EDIT: Yes, now it works… So i must think the delay action syntax changed after 0.92.2 as before i had the automation working also with that action…