Badges, can't get em to work

All documentation I’ve found is the Views for Lovelace UI, not being familiar with the setup from previous UI I’m struggeling to get badges to work.

First step is to get a badge showing the temp of a sensor once that’s done, add who’s home badges. But no.

What am I doing wrong here

views:
     
    # View tab title.
  - title: Home
    icon: mdi:home-assistant
    # Unique id for direct access /lovelace/${id}. If you don't specify one, it is added automatically.
    id: home
    # Optional background (overwrites the global background).
    background: radial-gradient(crimson, skyblue)
    # Each view can have a different theme applied. Theme should be defined in the frontend.
    theme: dark-mode
    # The cards to show on this view.
    cards:
      
        # The filter card will filter entities for their state
      - id: peoplehome # Every card needs an ID, if you don't specify one, it is added automatically.
        title: Personer hemma
        type: entity-filter
        entities:
          - entity: device_tracker.mickan
            icon: mdi:human-female
          #- entity: device_tracker.mickan
          # name: Mickan
          #- entity: 
          - entity: device_tracker.mattepsamsung
            name: Mathias
            icon: mdi:human
        state_filter:
          - 'home'
        card:
          type: glance
          #title: Hemma
          
      - id: badges
        badges:
          - sensor.23_temperature

I got it working, so for anyone ever running in to the same issue:

views:
  - title: Home
    icon: mdi:home-assistant
    badges:
      - sensor.23_temperature

But why can’t i change the name of the sensor? Is there a file where i can add the “friendly name” for sensors, i only set that up in the Tellstick conf for switches.

views:
  - title: Home
    icon: mdi:home-assistant
    badges:
      entity: sensor.23_temperature
      name: Ute

Looks like there is no ‘name’ option for badges,
Maybe give the good old Customizing a try.

I actually managed finally, don’t have the syntac available.

Yes, that’s way easier, thanks