Balboa spa custom component setup

I just took delivery on my spa yesterday and was hoping to get integrated with HA someday. My unit has the wifi component already installed. I am very happy to find this has been done! https://github.com/plmilord/Hass.io-custom-component-spaclient I was not looking forward to trying to get it working myself. I have little enough time to learn HomeAssistant! Thanks so much to those that have prepared the way!

Directions are simple enough but don’t correspond or work for me. directions say "/config/custom_components ". I did not have one. I did have an “/opt/hassio/homeassistant/custom_components” which has two folders -hacs and nodered.
adding "spaclient " folder there did not work even after restart. I made folder and moved to /opt/hassio/homeassistant/config and rebooted. A spa icon appeared in the list when I went to add integration but there was an error message which I can’t recall details of when I clicked on it. Since I hadn’t matched the path in the instructions, I moved folder into /opt/hassio/homeassistant/config/custom_components and tried again. No help. Now the icon is gone and doesn’t re-appear even if I put the folder back where it began to work (and reboot)! It was also not clear where the associated images folder is to go.

Full disclosure:
I am also running into the problem of out of disk space for /var/log mount. I would rather not ‘fix’ that but move entire install to RPI4 8G with 256G SSD I have on hand. I tried to make this work a month or so ago by restoring a backup to the new device but that didn’t work and the time I stole to try ran out… Current host is nanoPI NEO CORE2 on a shield that has a 64G SSD.

I am running:
version: core-2021.11.3
installation_type: Home Assistant Supervised
dev: false
hassio: true
docker: true
user: root
virtualenv: false
python_version: 3.9.7
os_name: Linux
os_version: 4.19.63-sunxi64
arch: aarch64
timezone: America/New_York


GitHub API: ok
Github API Calls Remaining: 5000
Installed Version: 1.11.3
Stage: startup
Available Repositories: 824
Installed Repositories: 5


logged_in: false
can_reach_cert_server: ok
can_reach_cloud_auth: ok
can_reach_cloud: failed to load: timeout


host_os: Debian GNU/Linux 10 (buster)
update_channel: stable
supervisor_version: supervisor-2021.10.8
docker_version: 19.03.13
disk_total: 58.4 GB
disk_used: 20.3 GB
healthy: true
supported: true
supervisor_api: ok
version_api: ok
installed_addons: File editor (5.3.3), Samba share (9.5.1), Portainer (1.4.0), Mosquitto broker (6.0.1), SSH & Web Terminal (9.1.0), Grafana (7.3.0), Glances (0.14.0), Check Home Assistant configuration (3.9.0), InfluxDB (4.3.0), Node-RED (10.1.0), Pi-hole (4.0.0), motionEye (0.16.0), Insteon MQTT (0.6.8), ESPHome (2021.10.3)


dashboards: 1
resources: 3
views: 2
mode: storage

Any suggestions would be appreciated. My preference would be to get this component working on the existing platform and then move to more capable unit.

Thanks again,

Q

Hi Folks
I am new. Before I start a Home Assistant project I need to know if its possible to integrate a Balboa Hottube the a WIFI interface from Balboa. Is it possible to read and write parameters (like temperature, LED colour, start/end pumps so on) to the tube through the wifi network?
I would be happy if you would answer me, or gladly someone else who is familiar with it.
Thanks a lot
Yours Alex