Beken Tuya light Component mqtt took a long time for an operation

Hi all,

I’m having an issue where my tuya light which I just removed using the tuya-cloudcutter is having a problem with operating. There are points in time where the light doesn’t work meaning I send signals to it to turn on and off and it doesn’t function. In the logs/debug I’ve noticed the following which happens over and over.

e[0;33m[W][component:205]: Components should block for at most 20-30ms.e[0m
e[0;33m[W][component:204]: Component mqtt took a long time for an operation (0.12 s).e[0m
e[0;32m[I][mqtt:282]: MQTT Connected!e[0m

I’m wondering if there was anything else I can try on my yaml for esphome.

esphome:
  name: ${node_name}
  friendly_name: ${friendly_name}

bk72xx:
  board: generic-bk7231n-qfn32-tuya

logger:

web_server:

captive_portal:

mdns:

ota:
  password: ${ota_password}

mqtt:
  broker: ${mqtt_broker}
  username: ${mqtt_username}
  password: ${mqtt_password}

sm2235:
  clock_pin: P6
  data_pin: P8
  max_power_color_channels: 6
  max_power_white_channels: 8

output:
  - platform: sm2235
    id: output_red
    channel: 2
  - platform: sm2235
    id: output_green
    channel: 1
  - platform: sm2235
    id: output_blue
    channel: 0
  - platform: sm2235
    id: output_cold
    channel: 4
  - platform: sm2235
    id: output_warm
    channel: 3

light:
  - platform: rgbww
    id: light_rgbww
    name: None
    color_interlock: true
    cold_white_color_temperature: 6500 K
    warm_white_color_temperature: 2700 K
    red: output_red
    green: output_green
    blue: output_blue
    cold_white: output_cold
    warm_white: output_warm
    restore_mode: RESTORE_DEFAULT_ON

Things I have tried.

  1. setting a static_ip
  2. using the api to send commands via HA with/without the key
  3. made sure there was no blocking traffic on the firewall (opnsense)
  4. Played around with the AP which is currently using a DECO mesh system

Any help or suggestions is greatly appreciated.

dont worry, all my devices are having the same issue

logger:
level: VERBOSE
logs:
component: ERROR

fixes it

For anyone wanting to implement this as well, the correct markup is:

logger:
  level: verbose
  logs:
    component: error