Home Assistant Community

[BETA] HA Client - native Android client for Home Assistant

android
Tags: #<Tag:0x00007f3754b90ef0>
#69

Ok, I created a new Issue on Github with some missing entities.

1 Like

#70

Is this working with groups? Personally I moved away from groups and work only with Lovelace

0 Likes

#71

Yes, for now it works only with groups. But Lovelace UI support is in plans.

0 Likes

#72

Will you be posting the source code?

0 Likes

#73

What’s the difference between this client and HomeAssist?
Does it support Lovelace UI? Is there a chance for IOS-like actionable notifications in the future?

0 Likes

#74

Yes. Not now, but definitely will.

1 Like

#75

I’m trying to build a client that looks and performs as an original Home Assistant UI. My main goals is speed, widgets, wear os support and native notifications.
Lovelace support is planned as well.

3 Likes

#76

You should add themes too

1 Like

#78

Good idea. Thanks!

1 Like

#79

Version 0.1.2 is in Google Play. With groups parsing fix and extended errors logging.

1 Like

#80

So here’s my log I think I’ve got everything set up correctly but front end showing blank.
HA VERSION: 0.78.3
Local HTTP: 8123
AUTH TOKEN

[Debug] :  AppLifecycleState.resumed
[Debug] :  Socket connecting...
[Debug] :  [Received] => Message type: auth_required
[Debug] :  [Sending] ==> auth request
[Debug] :  [Received] => Message type: auth_ok
[Debug] :  [Sending] ==> {"id": 1, "type": "subscribe_events", "event_type": "state_changed"}
[Debug] :  [Sending] ==> {"id": 2, "type": "get_config"}
[Debug] :  [Received] => Message type: result
[Debug] :  [Received] => Message type: result
[Debug] :  [Sending] ==> {"id": 3, "type": "get_states"}
[Debug] :  [Received] => Message type: result
[Debug] :  Parsing 41 Home Assistant entities
[Debug] :  Gethering views
[Debug] :  [Sending] ==> {"id": 4, "type": "get_services"}
[Debug] :  [Received] => Message type: result
[Debug] :  Parsing 20 Home Assistant service domains
[Debug] :  [Received] => Message type: event
[Debug] :  Parsing new state for sun.sun
[Debug] :  Settings change event: reconnect=true
[Debug] :  Socket connecting...
[Debug] :  [Received] => Message type: auth_required
[Debug] :  [Sending] ==> auth request
[Debug] :  [Received] => Message type: auth_ok
[Debug] :  [Sending] ==> {"id": 1, "type": "subscribe_events", "event_type": "state_changed"}
[Debug] :  [Sending] ==> {"id": 2, "type": "get_config"}
[Debug] :  [Received] => Message type: result
[Debug] :  [Received] => Message type: result
[Debug] :  [Sending] ==> {"id": 3, "type": "get_states"}
[Debug] :  [Received] => Message type: result
[Debug] :  Parsing 41 Home Assistant entities
[Debug] :  Gethering views
[Debug] :  [Sending] ==> {"id": 4, "type": "get_services"}
[Debug] :  [Received] => Message type: result
[Debug] :  Parsing 20 Home Assistant service domains
0 Likes

#81

Why had I never thought of wearOS support for Hass!?
This would be great!

1 Like

#82

I have Home Assistant 0.78.3
Now installed on my Huawei P10 HA Client 0.1.2. Aplha and i can not connect. I create on Home Assistant TOKEN for my Android but i can not connect…When try connect show me CODE 1… please help me.

0 Likes

#83

This was reported already: https://github.com/estevez-dev/ha_client_pub/issues/6
If you don’t have default_view defined in groups.yaml, it will show blank. Will be fixed in next version.

1 Like

#84

First of all go to menu - Log in app and take a screenshot of error showing there. Please report your issue with screenshot in GitHub repo. Thanks.

0 Likes

#85

0 Likes

#87

Looks like you have an extra space after your IP address. Check your connection settings in app.

0 Likes

#88

Yes good job start working… :slight_smile: Thanks

I start test this app.
But for first look i see that on web my first dashboard is HOME and end is DIAGRAM. In app as first show DIAGRAM dashboard and then show my Home Dashboard…And other dashboard also is not sorted as on webgui.

On diagram also not show diagram and show UNKNOWN

Also for some device not show in app icons… like alarm, scene, calendar google, media player

1 Like

#89

@pepeEL, if you really want to help, please report a separate issues for missing icons, diagram and tabs order to ourGitHub bug tracker. Thanks.

0 Likes

#90

Ok sended issue…

1 Like