Bitwarden RS add-on with two-factor and FIDO2 WebAuth

Hello community, I recently purchased a YubiKey 5 Nano and I’m playing around with it to see what it can do. I’ve been using Bitwarden RS add-on for some time now and I really like its two-factor authentication so I wanted to try to set up this key to be an enabled two-factor auth option but I cannot get it to work.

When I try to use the yubico built in option, it fails (I think) because there’s no environment variables set on the docker container which is apparently needed for the Yubico/YubiKey auth to function properly.

So, as an alternative, I’m trying to use the FIDO2 WebAuthn option. I walked through all the steps and it seemed to be working well until I tried to hit the “Save” button. The GUI just shows a “An error has occurred: Can’t recover challenge” modal.
image

Looking at the Chome debugging console it appears to send a PUT request on my domain to /api/two-factor/webauthn and receives a 400 error. I’m guessing the installation of Bitwarden RS doesn’t have anything looking for those PUT requests…

Anyone have a hardware key like the Yubico YubiKey 5 Nano working to authenticate to Bitwarden RS installed as a Home Assistant add-on?

SSL Must be enabled. Mine worked no problem.

I have SSL enabled on BW and Home Assistant.